ATC no longer talks to you on Xbox and PC


Since the update like 40 minutes ago ATC no longer talks to you, at all, talk about an immersion breaker. Havent tested it on PC yet. And yes volume is 100% even text messages from ATC dont come in anymore.

PC user here, currently having the same issue. However I’m still on since I did not know there was an update today.

Worked fine forme on that version but since the new update an hour ago no Text or Voice from ATC at all only our own communications. Really immersion breaking. But yeah same issue on PC just tried it.

I can’t repro this issue, I’m able to talk to ATC and I can read and hear the reply. I’m on PC, without any third-party marketplace item / mod

Very strange, I have it on Xbox and on PC, on PC I have a lot of 3rd party items but on Xbox none so its very strange, some others said they have the same issue.

Ok strange after 3 restarts it works again, weirdness

I switched my ATC voice to the built in offline option, and it works. Maybe the azure servers are being wonky since I also kept seeing occasional disconnects here and there.

1 Like

Wasnt just the voice was the text too it didnt show the text even, works again now after 3 restarts

ATC works for me upon and after take off and mostly during flight. Now I’m getting either no ATC close to landing or heavily delayed ATC after landing. ATC not calling runway or traffic pattern. Hopefully restarts will fix.

XBOX user - i found that retuning between COM1 and COM2 sometimes brings it back but not always. Hope it is resolved soon as its an important part of the game.

Xbox player here. Same issue. Last night the ATC just went silent on me. No voice, no text. I could only see my replies in the ATC box. It was like I was responding to myself. Is this a known bug on the Xbox?

1 Like

Yes only fix is restart the sim that will fix it, but it can happen again at some point

1 Like

Personally, I haven’t found anything that has fixed this issue. After checking all settings and restarting the game (as well as restarting the Xbox), it’s still happening from the very beginning of every flight :confused:

1 Like

Am having this issue also, when starting a flight from stand at an airport. At some point whilst taxiing and needing to switch to tower frequency it goes faulty