ATC No longer works - SU5

I have an empty community folder. I have tried multiple planes/airports with the same issue. Ground, tower, ATIS are all gone. Unable to call ground services or even call ground to clear for take off. It is completely gone. All I see is what I can presume is VFR "Traffic"and announcing what runway you are going to use.

I have the same problem on Xbox I don’t get even messages like if I ask where is the airport but some times my buttons which I can press change like after a landing request but I don’t get any reply of the tower
This is really frustrating:(

1 Like

Yes, indeed the ATC got worse, which is an understatement after SU5. I turned it off, but the CTD’s happen on all flights. Removed rolling cache, AI Traffic, etc, but when it does not CTD, it freezes.

Ditto on ATC comm problems–and also flight planning is nerfed. All one can do is fly direct. No SIDS, STARS, VORS or approaches available. None of the flight plan options work. I have tried various a/c at various airports. All same.

1 Like

I had this problem as well initially, but resolved (that part of it) by removing the Content.xml in the MSFS packages directory (look a couple levels up from your Community folder) and letting it regenerate it on next launch.

1 Like

I had the same problem. Do you use Navigraph Charts? I had to put the AIRAC data and in game chart files back in the Community folder in order to get any SID,STAR or Rwy data. Thank goodness that Navigraph wasn’t causing my CDTs. I hope this helps someone…

1 Like

I’m having the same issue. Filed a Bug Report. No files in Community, not in Dev Mode. All default AC and Scenery. This is after patch. Everything worked well in SU5.

The suggestion to empty Community Folder, delete Content.xml and let the sim rebuild it usually solves most problems.

The other possibility is if you’re a Navigraph user and you just removed Navigraph by deleting the folders in Community rather than uninstalling cleanly via NavData Center. If that’s the case, use the workaround above.

1 Like

When using Assist, ATC would clear for takeoff.

With update 5, ATC states “Cleared for Takeoff” in the preflight cinema portion of loading the flight, but not once loaded, sitting on the runway.

This was not a problem prior to SU5, and affects multiple aircraft. I made sure no add-ons were installed and nothing in the community folder.


Hi guys, I think I found the problem :slight_smile: When ATC is not working and you have the old version of AIRAC loaded in the sim, you need to update the AIRAC database in NAVIGRAPH NAVDATA CENTER. There was an update 1.0.0 after this Update 5 in MSFS2020. See here: Release notes - AIRAC Cycle - MSFS Navdata / Release Notes - Navigraph

Thank you, very kindly. That did the trick.

1 Like

Talking to myself or listening to my FO talk to herself is fun too…

1 Like

I had the same deal earlier today. ATC is infuriatingly broken right now.

Every Time after Updates Proplems over Proplems in MFS 2020 What is this for a bad Job . The Scenerie Mods , the most dont working after SU5 Update . Horroable for the Freeware Developers.

1 Like

Turn off live traffic under data. Only way I could get it to work right, and only way I could stop the FPS from dropping from 40-50 down to the teens. Guess it was not fixed after all. lol

Live traffic? I thought there were just issues with AI traffic. Also, I don’t have any issues with FPS.

Weird. I have been getting great frames, til half way through flight it drops to around 20, upon descent i drop into teens. But yea, as lame as it is, turning off traffic in Data field has cleared up both for me…sucks cause whats the point of this game to not be able to see other planes flying…

1 Like

Same here.

Same here was oke before.

I have this issue now with SU7. Anyone knows how to solve it ?

I tried:

  • Deleting Comunity Folder
  • Turning off live traffic and multiplayer
  • I have the latest AIRAC loaded (via Navigraph Navdata Center)
1 Like