Automatic Bus Tie not Working

Have you disabled/removed all your mods and add-ons?
No.

Are you using Developer Mode or made changes in it?
No.

Brief description of the issue:
None of the scenarios described in the WT documentation lead to the bus tie automatically closing.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:
Turn on batteries, turn on external power, note bus stays open. Turn on APU, turn off external power, note bus stays open. From completely powered down, turning on one battery doesn’t automatically tie the bus. It matters not if the right or left battery is the initial battery turned on.

PC specs and/or peripheral set up if relevant:
Xbox Series X

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Interestingly, after a flight, parking and shutdown of the engines, connecting external power will automatically close the bus as expected.

Something fishy is happening at C&D.

Ok, more data:

I just completed a flight in the Longitude, again I had no automatic bus tie from C&D. Again, I did have automatic bus tie after landing, shutdown and connecting ground power.

I just set up a second flight in the Longitude (after exiting to menu from the previous, setting up a new flight plan in the World Map and loading into the cockpit) and I now have automatic bus tie from C&D in this subsequent flight.

EDIT:

Allow me to clarify a couple of items here. 1. I’m on Xbox. 2. I usually quit MSFS whenever I’m done flying for a session, rather than use Quick Resume. 3. Therefore, the first flight where I’m not getting automatic bus tie function is on a first flight in the Longitude from a fresh boot of the sim. Where-as the second flight is a subsequent flight in the Longitude during the same “play” session of the sim.

1 Like

This issue appears to be exclusive to the Xbox version.

I have installed AAU1 Beta on my PC and I am not seeing this issue, at all.

Have you posted in the WT Discord? I swear those guys don’t sleep, or they’ve cloned themselves to be able to respond to questions, always responsive and engage in solving even small issues. Really detail oriented.

PS, what is the expected behaviour, I’m not even clear if/when the bus tie is supposed to be open or closed. Is there a consequence to the plane’s health or behaviour in the sim, other than the indicated button?

I don’t have a Discord account.

I’ve had very good results communicating with Matt @ WT here in the beta forums regarding other issues.

Furthermore, this is the beta forum and is meant to be monitored by the developer team. I’m trusting that continues to be the case.

Apologies if I come across as gruff — that tone is not my intention. I just am a bit resistant to having to communicate about the sim across multiple communication platforms. I’d rather just stick to this forum and, unless otherwise strictly instructed, avoid alternates.

1 Like

No problem! I think I have the same set up as you, Xbox X, no mods, Premium Deluxe AAU1 beta, so I’ll do a flight and try to pay attention to what the bus tie button does without me doing anything to it…

I’m sure you have the manual, but here is the page that describes it, if it helps.

So I think they only Tie when (A) only one bus has a power source and (B) the unpowered bus needs power, automatically?

1 Like

Thanks. I’m familiar with the manual and my basis for the errors in the Xbox version are pulled from the functionality described within.

I, specifically, note that on first use with a freshly launched sim:

  • Turning on one battery doesn’t result in the bus automatically closing
  • Activating ground power doesn’t result in the bus closing
  • Turning on the APU doesn’t result in the bus closing

OK I’ll see what mine does, I follow the checklist in the same doc for startup.

1 Like

OK so weird results. Cold start of Xbox, launch MSFS, spawn at parking, watching Bus Tie through various combinations of:

  1. Left / Right / L+R Bat
  2. Ground power + L / R / L+R Bat
  3. APU + L / R / L+R Bat
  4. APU + Ground power + L / R / L+R Bat

And the Bus Tie seemed to close whenever 1 side had no power source but the other did. Even the L Bat only would close the Bus Tie and power the right side… so I thought it was all fine…

… but then I rebooted Xbox and tried again … it stopped working, can’t get Bus Tie to close at all from a cold and dark start. Will try to see if it works after a flight as you said. But what’s weird is that it did work from cold and dark just the one time! Ugh.

Finally I did a flight from cold and dark, again automatic bus tie did not work before takeoff, nor did it work in the air.

Mid flight with both engines running and APU off, I turned off Left battery and Left Generator, and the Left avionics went dead, because the automatic Bus Tie didn’t close. Same result with the R bat.

But after landing, turning APU on, then both engines off, the Bus Tie would correctly close automatically to make sure APU was supplying both sides.

I feel like that was my experience, but I’ve never seen it work again on the first try since.

I did read that the “Bus Tie” button itself is just an indicator - not a Pilot-selectable input (at least in Sim). I think that’s what WT said in their Discord channel. But it should work properly since they did such an amazing job of modeling the entire electrical system for this AAU1 update. I believe that the IRL checklist does include turning off the L and R engine generators to test the bus tie before take off, but I haven’t had a chance to try to find it… I’ve seen videos of other Citation Jets do this test pre-flight.

This is the case only when on the ground. It’s my understanding that the bus can be tied when in the air, such as for emergency purposes.

From the manual:
“When on the ground, pressing the BUS TIE button performs no action, as it is fully automated. Pressing the button in the air toggles between the two available states.”

I think I found the issue, and reported it also on the Working Title Discord.

If you spawn in cold and dark, don’t do anything except turn on your L+R batteries, then open the Electrical Synoptics page on the MFD and look at the position of the 3 generator switches - closed or open?

IF the 3 generator switches are CLOSED (as if their respective engines are running and supplying power) then the Bus Tie won’t work as expected (probably because it sees the gen switch and thinks it is supplying power even though it isn’t). Also, flipping the visible generator switches (Off, Reset, ON) doesn’t change the status of the switch on the Synoptics page from closed to open as it should.

But sometimes when you load in (or after a flight, power off then on again), you’ll see the generator switches are OPEN (as they should be when the respective engine isn’t running). And in this configuration, the Bus Tie will behave as expected. L+R Bat ON, then Ground Power ON, and Bus Tie closes to connect both sides to ground power.

Finally - if you happen to be in the first scenario, where the generator switches are closed (ie “ON”) but no engine running, and Bus Tie isn’t working… then when you actually start each engine, then the visible generator switches start to control the open / closed position displayed in the Synoptics page properly, and then the Bus Tie does work as expected. You can test this by starting both engines, then turning OFF 1 generator, turn OFF APU and Ground, and watch it close.

I think I found the source of the logic, but it’s a question of whether the plane’s initialization of first flight can be consistent in loading the switches in the right place … I’m guessing!

2 Likes

Nice detective work!

I’m starting to wonder if the issue also does exist on the PC and the one time I tried it was the one (aka first) time it worked. I didn’t try it out on PC again.

I think there is a general issue with initialization in the sim (not just longitude), getting initial settings to be consistent seems to be a lottery. Example, opening Weight & Balance the first time, it’s generic, but if I close it and open it again, it reflects the tanks and passenger, cargo settings of the plane.

2 Likes

I definitely agree with you. There are some real oddities to how the aircraft are loaded in, too. During the pre-click Fly screens, the aircraft are powered up and running. When you click fly you can often hear systems shutting down. This is especially pronounced on the A310.

I don’t understand why that is even a “thing”.

My guess - Jorg Nuemann wanted people to be able to hop in and fly, so “On and Configured” is the default setting, and to get the plane to start cold and dark, they actually have to turn everything off upon spawning in… And, that would make sense as a root cause of this bus tie issue - With engines on, the generator switches are closed, and if the sim shuts the plane off too quickly maybe the gen switches get stuck in that Closed (ON) position, and the plane logic doesn’t recognize or expect that when the user starts the electrical system.

1 Like

At times it feels like the approach was Video Game first and Simulator second. It feels like they are scrambling to undo that approach, thankfully.

Maybe they really underestimated the success of the title (or had to go way out in a limb with management to even get funding for it) and figured it really was going need to be video gamey to appeal to a larger audience, which would equal sales.