Avionics gone after Update 10 in Cessna Longitude

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

Developer Mode

Brief description of the issue:

Avionics white screens PFD and MFD

Provide Screenshot(s)/video(s) of the issue encountered:

see screenshot

Detailed steps to reproduce the issue encountered:

no idea how to rectify this.

PC specs and/or peripheral set up if relevant:


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

If you’re using Dakfly’s Longitude Flight Dynamics Mod, you probably need this hotfix.

Thank you, CausalClick for the tip.
How can I find out that this is Dakfly’s Longitude Flight Dynamics Mod?
I have never carried out a hotfix. What is the procedure?

You would have installed the Flight Dynamics Mod in the sim’s Community folder. The hotfix would be applied the same way.

So just a drag and drop into Community Folder?
Okay, I will give it a try.
Thanks again.
I have to say, this is the first issue I have ever encountered in the Sim since I purchased the Deluxe Edition back in 2020. Everything has always worked brilliantly.

CausalClick, many thanks. All sorted hotfixed worked.

1 Like

I had the same issue. I was using the Asobo Cessna Citation Model 700 Longitude Performance and Flight Dynamics Modifications Project Version 1.95. I need to see if there is a hotfix for that. My only solution was to delete it out of my CF.

1 Like