Axis and Ohs: Help and questions

Hi, please send me this new version of AAO.

@ PilotEmu9913130

See my post above.

… please send me your proof of purchase and I will provide the new version and instructions about how to implement it. Email address is on the last page of the AAO manual.

Note to those who already have the 2.06: I made an automated installer app too. When you re-download the package again, you will find an additional ZIP with the WasmModuleInstaller app. Instructions have been updated as well. The app hasn’t been tested a lot, so if you prefer the manual method, that is still in the instructions too.

2 Likes

The installer worked great and the aircraft are responding now to the x-touch.

I disabled AAO from automatically starting since it was mentioned not to start it before the aircraft was loaded in the sim. Not sure if that was needed.

Thanks for providing this workaround.

… perfect Oliver. Well done! AAO and the x-touch are friends again.

Hello @ll,

since feedback has been positive, I have decided to take the plunge - version 2.06 has been uploaded to the shops, it should already be available on SimMarket.

The workaround instructions and the installer tool are in a separate ZIP file, please make sure to read the release note and the instructions carefully.

Once MSFS has been fixed you can deactivate the workarounds with the installer tool and use the standalone module again.

AAO_WASM_INSTALLER

8 Likes

As always, many thanks for acting so quickly to help your customers. If only Asobo … Naah I won’t go there. :wink:

1 Like

I sent my PM at lunchtime but version 2.06 is now already on the SimMarket. So I downloaded and will try to get my gear working again with the CJ4. Your response to help your customers is very fast and professional!

Thanks!

Thanks for this solution; In my case it does not work, let me explain: I installed version 2_06_b08 and following the manual of AAO_2.06_MSFS_1_15_7_crash_workaround I have executed the exe, I have verified that the modifications in panel.cfg and layout.json have been written correctly, I have executed the sim and a Once my CRJ has been loaded and in the cockpit with engines running I have loaded AAO, it has recognized the plane and loaded the template but … no assignment works except the AP.

What am I doing wrong?.

best regards

Try a “clear config” , “resign controls” and apply your template again. Hope that helps.

What am I doing wrong?.

Hard to tell. Make sure that you apply the WASM module to the base model “Aerosoft_CRJ_550”, “Aerosoft_CRJ_700” not to one of the extra liveries. Those may have a panel.cfg too, but people told me that the WASM doesn’t work when it is in there.

Hello @ll JustFlight customers,

here is an open link to the workaround app and instructions, should those not show up in your account:

Best regards

2 Likes

hello,

Its working great and in want All my Hardware take with your addon.

I need help

everywhere have a gauge icon for the streamdeck i can See the Alt and Rpm direct on streamdeck. i have that with flight tracker but sometime Crash my streamdeck and i think its to much different addon.

Pls send me a Profil with that for the normal 15 Button streamdeck.

Many thx for the help

Thank you Ic4c and Oliver for your responses.
Deleting and reassigning the template did not work.
I have verified that the WASM module is in the CRJ_500 and CRJ_700 folders.
The only difference I have found has been in [VCockpit04] and in the “texture” line where it had “$ efb_display” instead of “$ PFD”. I replaced it and it still doesn’t recognize assignments.

I told Oliver about this but thought maybe someone else has seen it. CRJ purchased from Aerosoft Store. Used the crash workaround installer. The CRJ 550 works. LVARS can be rea from the scripting menu and HC Alpha/Bravo works as before the world update. The CRJ700 does not. Script reading fails and none of the buttons work. Any ideas?

Any ideas?

Maybe. Please check the layout.json file - is there one reference of the “LorbyLVarHookWASM.wasm” or are there two of them? There must be two, one for each CRJ model. I didn’t anticipate that in the installer, and it is definitely possible that there is only the first one that you installed.

Hello @LCplCrabby, @Fuentes000,

I just tried it on my end, and AAO definitely works in both the 550 and the 700.

  • Make sure that the WASM module is in both panel folders
  • Make sure that both panel.cfgs have been altered
  • Make sure that BOTH wasm files are present in the layout.json, one in the 700 folder, the other in the 550.

But I probably cheated, because I disconnected AAO (click on the green LED) when I switched from the 550 to the 700, and reconnected it after the 700 finished loading - because the CRJ always was trouble during the initialization process.

Hello @ll,

the MSFS hotfix 1.15.8 is now live.

The sim is no longer crashing when a stand alone WASM module is present, so things can go back to normal.

  1. Do I need a new version of AAO? No, the 2.06 b08 that is in the shops will work fine

  2. How do I remove the workaround? panel.cfg and layout.json must be reverted to their original state. You can do that either manually, by reinstalling the plane or with the WASM installer tool. If you were using the tool and it throws an error when you try to remove a configuration, check the plane folders manually - the original layout.json and panel.cfg files are there, renamed to “.original”.
    → After that just reinstall AAO

  3. If AAO is only displaying a white window in the taskbar, delete the following folders:
    C:\Users…\AppData\Local\Lorby-SI\LorbyAxisAndOhs_MSFS.exe_Url_czjzikxvfp4omouhsqicacm52dqowlpu
    (= everything that has those cryptic characters at the end)
    ATTENTION: Be mindful that this is not the same folder as the one with the configuration database - that is LORBY_SI and you should not delete that!!

I don’t know if (3.) happens everywhere, but it happened to me.

4 Likes

Stunned how quickly they pushed that out! But thank goodness

Thank you for always being so attentive