Baron HDG pointing to a different direction


When flying on the Baron, I pressed the HDG knob to have the pointer automatically centred on my current direction, that was 240º. Instead, when pressing the HDG knob, the pointer always set to 300º.

I don’t have any mods installed


I’ve seen this a couple of times in the C172 G1000. Pressing “D” solved it.

That’s the default keybord shortcut for aligning the gyroscopic heading instrument with the magnetic compass, so I guess it shouldn’t be required, or even functional, with a G1000, but apparently it can be used to circumvent what seems to be a bug.

1 Like

I’ve seen an issue regarding using slew mode to spin the aircraft about, and even pressing D in that scenario will not set the compass correctly. That was definitely a bug.

No, pressing “D” didn’t help. Actually, a couple of minutes before it worked perfectly fine. It’s impossible that in 2 minutes the compass gets an error of 60º.

@ MCGordito7967


I’ve discovered this bug in times of day one :slight_smile: it’s problem with slew, so pls answer if you did some changes with slew. This is first question, important because what I discovered and sent to Zendesk is, if you start your sim at parking without start engines then, synchro heading bug with instrument/real heading can be not correctly centered/aligned. Don’t do slew if your engines are not ON. This is bug and also solution to it as I mentioned.

When a bug is involved, I guess nothing is impossible. :wink:

All know is that I’ve seen the bug in the G1000 a few times, and the last time it went away after I pressed ‘d’. That was also a situation where it had been working a few minutes earlier and suddenly was off by a similar margin.

Maybe it was a wild coincidence, but I thought the workaround was so easy to try that I decided to share it.


you have been lucky probbaly. try that my explanation with slew prior start engine. Try and then start engine. If this bug is still presented, no other workaround than only avoid slew before start engine/s. “D” is solved problem only with steam gauges aircarfts, they will center heading as is feature with magnetic error and need after time correct this bug as in RL.

I never slew. I don’t even know how.

No problem,

look to key bindings for this feature, as standard key “Y”. Then move/rotate your aircraft lef or right (check bindings) and set again off slew with Y. Start engines and try D :slight_smile: With aircrafts automatically aligned magnetic heading is D not functional.