Beachcraft Turbo Mod G36

For some strange Reason I can’t start the Engine with this Mod. am I missing something. Yes I have changed the General over to Modern, also the Fuel to Manual.

Are you using the starter switch on a Honeycomb Alpha or similar ?

If so you need to check the “QuickEngineStart Alternative” folder within the mod directory for small change that needs to be applied

Thank you Paul for the advice that is exactly what I am using

Yes Paul I 'am . I used the advise you gave me and I got the engine running then I could not get the plane into the air. I think the movement on the Elevators need to be adjusted and also the Rudder and Ailerons , I went roaring down the runway and pulled back on the Yoke the plane would not lift off the runway. I then took the mode out of the game and the old G35 leapt into the air. The way I started the engine is I used the switch on the Alpha Yoke and stopped it at both and then used the mouse button to start the Engine.

If you go to external view and move the yoke do the elevators move correctly ?

I tried it Twice last night and when I have the Mod connected it defiantly retards the movement of the Rudder, Elevators, and Ailerons, from what I see in the original plane. It looks like there movement is cut down to approximately 50% of there full movement.

I just Downloaded the G36 Turbo Mod Tonight after a friend recommended I try it over the Working Title G36 (he has several hundred real hours on the G36 Turbo and says this flight model does a fantastic job of modelling the real Aircraft) I’ve been using the Working Title Mod but found this to huge improvement. Kudos to the Author! I will be donating to the Cause.

However I have run into a problem. I Can fly fine if I start on a runway But I cannot get the Engine started from cold and dark or a hot start after a shutdown. I’ve tried the Priming process to no avail. I cannot get the engine to fire up (It cranks over but does not fire (up) and don’t know if the is a different starting procedure for the Turbo engine.

Anyone got any insights?


1 Like

Seems to start fine for me. Had to give quite a bit of throttle for it to catch but it starts up fine.

Are you using Revision 3 of the Turbo mod?

If you had the other G36 Improvement Mod installed, did you remove that (the two mods can’t be installed together)

Are you using the “Modern” flight model in the Options menu?

I’ve done a lot of cold and dark starts with the Turbo with no issues.

How are you starting it ? Is it an external device or are you using mouse and keyboard? If an external device does it start with the mouse. What about CTRL+ E ?

The Bonanza has a highly accurate simulation of engine flooding and other goodies. It is not starting with “STRG + E”.
You must enrich mixture to the max, maximum propeller RPM lever, and thrust lever to 10% engine power to start it and keep a cold engine running. When the engine and the oil is hot, it runs with lower power too.

See the highly detailled manual that comes with this mod :slight_smile:

1 Like

I tested this last night and think triggering the SimConnect Event for Magneto Start when tied to pushbutton does not engage the starter long enough even if the Button is held pressed.

When I hold the Mag Switch in Start on the Dash Pane lThere seems to be some background timing for the MAG Switch on the panel that is not used if you trigger the Sim-Connect event. The End Result is that if you hold the Switch on Start the engine will start after about 2 seconds.

Using a Streamdeck Button to generate a keyboard press (CTRL+E sim-connect: ENGINE_AUTO_START) I can get the engine started However if I use the StreamDeck to drive SIM-CONNECT:MAGNETO_START event the engine will NOT start, seemingly because the starter does not engage long enough for the engine to catch and fire up.
I really appreciate the meticulously modelled engine but this may present problems.

BTW this is aircraft to me FEELS truly superb. It has almost all the characteristics of the real aircraft as I recall, and none of the Twitchiness that plagues many of the stock aircraft.

1 Like

Would be cool if they fixed the mixture on this plane. Annoying needing to lean the mixture in climb to get proper fuel flow. It should also be renamed Turbo-Normalized Bonanza. Turbo Bonanza is a different animal

Also Found a bug in the Electrical Routing. The MFD is controlled through the Avionics Power Switch in the Stock G36 and G36 Improvement project (and it should be IRL too) Turning Off AVIONICs in the Turbo does not shutdown the MFD.

I am pretty sure the mod comes with an alternate .cfg file that can be swapped in an allows for faster starts with controllers that have the issue you describe. Check the documentation.

The issue with the mixture is a limitation of how MSFS handles mixture.

Yes the alternate engine.cfg solved my starting problem.