Bing Maps and Photogrammatry Not Loading Unless Game is Set to "High Priority"

Thanks for the replies so far and forgive my ignorance, but the fact remains I’m able to replicate the problem and solution everytime. Its just the solution shouldnt even be something that should be done.

Makes me think its maybe my processor just chugging on normal priority and setting it to high priorty gives the cpu that extra kick to process the streaming.

I dont think its server side because when in high priority mode everything streams in perfectly.

Hi that’s one of my favorite settings.
You can give it that command so that it always runs on high priority automatically. I’m recently trying another setting and it seems to work well too.

Always run MSFS 2020 in high priority

CMD as administrator

regedit (Press Enter)

We look for the following route

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options

Right click on Image File Execution Options > New > Password and put > FlightSimulator.exe

Right click on FlightSimulator.exe > New > Key and put PerfOptions

Right click on PerfOptions > New > DWORD Value (32 bits) and put CpuPriorityClass

Double click on CpuPriorityClass and put in information of the value 3

Wow thanks will def set this up. Only thing is that when msfs is set high priority, the rest of my computer runs like ■■■■. Might be high time to actually installing my i7 9600 thats been sitting around with its new mobo

You can try these 2 things together they seem to work fine

what a strange combination :flushed:

This CPU have only 4 cores… May be somewhat runniong in parallel eats so many resources, that you must force the OS to give parts of MSFS a little bit more time-slots ( a setting which is normaly not recommended neccessary ). But we can not say something without screenshots of e.g. taskmanager etc, about CPU load. At least If I see that you use VR, I have some “bad boys” in mind :slight_smile:

1 Like

Perfect insight, Micha. As soon as I’m home tomorrow, I’ll try to grab some screenshots of task manager while the game is running.

I mentioned earlier as well that I have an i7 9600k ready to install. Just gotta move some important stuff off my ssd first.

1 Like

I seem to have the same problem…

Just that it doesnt matter if i set to High or not. This happened with the moment of the last Worldupdate for me. I remember how i updated, went to the mountains near west coast and saw that the terrain isnt loading anymore.

One can see it here on the pic. Look closely, the upper half has a different color and no detail at all, then a part comes with yet another color, rectangle shaped and then the full crisp texture comes. This seems to happen everywhere in the US now for me. Just not always. Ive made a few flights

This is LOD 250.

unknown.png (2542×978) (discordapp.com)

unknown.png (1565×1036) (discordapp.com)

unknown.png (1412×1075) (discordapp.com)

Ive done a lot of things already. Cleared caches, restarted router, tried different planes, routes, deleted content.xml and usercfg.opt and a few other things.

What i notice is that it doesnt seem to load data anymore and the CPU is not really doing much…
The problem is that an internet speed test shows all good. No issue with connection.

Ive tried to change the prio to high but that doesnt seem to help.

This problem appeared over night, first time i saw it was on day of update.

This is how my sim (with the same settings) looked 2 weeks ago. Ive basically never seen the terrain load in. It was simply there. Now i see it loading just a few hundred m infront of me.

unknown.png (2335×1198) (discordapp.com)

unknown.png (2560×1440) (discordapp.com)

ANd here one can see that it simply doesnt load nicely.

unknown.png (1049×736) (discordapp.com)

There would be a lot more to load because if im over the bad spots it will load in detail. So basically the detailed data is somewhere, it just doesnt load.
What can it be?

I9900k
rtx 2080
32GB Ram.

i try this when i right click on “new” i dont grt the “password” option .
can you please explain in better detail ( i am old and stupid)

No Please
Do not say that.
It was my fault for not explaining myself better.
You can write yourself or double click and it will apply automatically.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\FlightSimulator.exe\PerfOptions]
“CpuPriorityClass”=dword:00000003

Download

thank you for that i wil give it a try

1 Like

Tss yesterday i had a ctd now this!? Man this game becomes to get worse. Look at the poi’s detail just poor nowadays. Wqs flying over italy and noticed some real problems ,ith the photogrammetry and the pois that don’t load at all a they should. Can somebody see if you have the problem also???

The pois dont load even tried rebooting. Cache on or off doesnt make a difference. Other citys seem to be fine. Really shittie!

it looks like PG… can you share the exact location so that we can made a compare ? ( I not know each street / poi in italiy :wink: )

PS: and how is the effect of the process-priority, as the topic here is ?

Its in Peretola airport near firenze. There are a lot of pois there and only 1 out of 10 load properly! Piaza dell duomo is the only poi in the vicinity that looks good as it should. The rest looks like garbage.
Havent tried the priority settings set to high will try it later.
Thanks for the reply mate!

Weird i wanna try the high priority setting but when i open rask manager and select the game right click i cant go to details so i cant set it to high priority

let us check that area first… I have anyway some doubts about that “high prio setting” , that should never be necessary :wink:

Indeed i found it set it to high doenst do anything. But when.i go to germany to maybe 30 pois next to eachother every poi looks absolutely clean. Really weird that the pois in italy dont load properly

sorry, I killed in meanwhile my system and had some work to get it running again :joy:

Then… I searched your POI ( I used your image where seen "Giardino… " . But in first tries I never get POIs on the global map, but I assumed where you was. Then sometime later I get the POIs


Thats what I see, and it looks like a PG building and yes, because of the POI I also expected a 3d model, but not sure whether this is allways the case.
At least bit left, there is a correct 3d model POI.

your pos:

POI bit left:


At least, you not need to change somewhat at your system :slight_smile:

No indeed i was playung online with a friend todzy to see if he has it too. And indeed he has the problem too even in the same area. But sometimes even worser then me. Sooo this game is broken like hell!! And indeed the cathedral is the only poi that seems to be perfectly the rest is plain garbage!!!
Dont know whzt to do about it anymore. Think im going to let it like it is and wait for an update. Cause this looked much better before then now

question is still whether for all marked POIs realy special manually created 3D models exist… may be not and then we see the photogrammetry buildings.

Indeed that can be. But i played this game and all i do is search for pois. Never seen any bad pois like this.