Black Square Analog Beechcraft Bonanza A36 / G36

Some progress on the panel modifications: Reworked all graphics for:

7 Likes

Yes, I finally got this 2 or 3 days ago. I thought I might find this a bit tame after the King Air but not so. Really enjoying it and like the KA it has been a great purchase for me. Before I bought the KA I did wonder if these mods were overpriced. But what can I say? For the last 2 or 3 months all I have been flying has been the BS mods and the PMDG 737 despite a hanger full of other great quality AC. Says it all really.

Looking forward to the Baron too especially so with the 25% discount.

I’m thinking of buying the PMS 50 GTN 750. Is it worth the £25/£75?

2 Likes

I agree…I think they are a little overpriced but this is what I was expecting from the Deluxe/Premium package from Asobo.

I bought the PMS GTN750 over a year ago. Yes it’s worth it but all gps builders have been having a rough go since WT started revamping everything so I don’t use it much when BETA testing.

If you haven’t looked into Navigraph you might check it out. Their ingamepanels-charts 8 has been a real value lately. Able to look at taxi ways easily and topographical charts are great for mountain flying.

2 Likes

Thank you for the reply :slightly_smiling_face:

I was a subscriber to Navigraph until recently but dropped out when they increased their subs. I can see however that the charts could be very useful here.

That said, I am still tempted with the £25 annual sub with a view possibly to the lIfetime purchase of £75. Not cheap but it could maybe have long value across multiple aircraft :slightly_smiling_face:

1 Like

I do wish Microsoft would let those of us with the standard version buy just the default Baron.

I’ve used it for about a month now and really like it. It’s continually being updated and the developer is very open with his communication on Discord.

2 Likes

Does not remember the KNS 81 power state.

hi all,
doesn’t seem to be working for me regarding start up
with the checklist correctly performed,
when I engage the starter to both, the engine rumbles but doesn’t start…
I installed the 1.1 update (clean install)
I guess my bindings on the alpha honeycomb are still incorrect,
however my bravo honeycomb commands seem to work fine

a reference how to bind the alpha controls correctly to the black square bonanza could really help me out,

thanks a lot

hans
here my alpha set up ,which doesn’t seem to function

I have unbound my Alpha magneto/starter. I would recommend to use the mouse for the starter (turning it longer to the right than it is turned by simple click/button press). Sometimes it takes longer for the engine to start. Sometimes I have to repeat the “throttle full/fuel pump high” priming procedure before the engine eventually starts.
(61) Unbenanntes Video 10 - YouTube

hi all,

disregard my previous post, if you take your time to be vigilant not “to flood” the engine and be carefull with the magneto start it works perfect with the “classical” alpha honeycomb set up

blue skies

hans :sunglasses:

3 Likes

Yes, this happens to me without fail every time. Always starts on the 2nd attempt.

1 Like

Just curious…
Full Throttle
Aux Fuel Pump for 5 sec (not to fast)
does not do it?

Note: the Honeycomb Yoke, and also the Logitech/Saitek switch box, send a single pulse to the simulator when first switched to start which causes the aircraft to crank the starter for whatever time is set in the config files for that plane and then disengage.

Using the mouse to engage the starter causes the starter to crank for the whole time the starter is engaged by the mouse.

Having the engine primed correctly ,throttle set right etc is hence going to be much more critical when using a Honeycomb as you only get the preset time and need the engine to “catch” within that preset time. Cranking with the mouse gives a more realistic start and more leeway for error in the start procedure as it keeps cranking as long as the mouse is held.

2 Likes

What Gauge is this, that keep poping up in MSFS Aircraft with newer Garmins ?

Mid-continent MD41-229

2 Likes

Yep. Full throttle, aux fuel pump on full. I tried initially with the 2-3 seconds as recommended and that has never worked, so increased to a count of five. I have the Alpha yoke and use the markings on the side to judge where to put the throttle for the start. I have it straddling the first mark, any lower and it doesn’t catch at all.

2 Likes

Left button switches the autopilot between VOR and GPS I believe.

Right button arms the approach mode for ILS.

Thanks, saw this after I typed my last reply. Will give it a go and see if makes a difference.

Using the mouse does not guarantee a start but give you a better chance.

Yes, I also use the fuel pump for slightly more than the 2-3 seconds from the checklist. But the most important thing is the throttle position when cranking the engine. If the throttle is too open, the engine will not start. Close the throttle completely and scroll with your mouse wheel 2-3 clicks to open the throttle just a little.