Black Square Steam Gauge Overhaul - Cessna 208B Caravan

That was my bottom line yesterday:

With WT addon (not just stock but additional) 530 → I can properly use the AP but importing a flight plan from the world map doesn’t work. (Different behavior with PMS750 - I now am able to import a FPL into the 530)

Without WT addon 530 → I can import a flight but the AP acts up. (Same behavior with PMS750 installed)

Given the findings with the 750 AND WT‘s 530 installed, I think I have found my configuration from now on. Nevertheless, it’s quite odd behavior and still subject to testing a new flightplan after landing.

Yes, the WT GNS530 loads the sim (ATC) flight plan only when starting a flight.
If there is a hot switch to the GNS530, it doesn’t load the flight plan again so it’s empty.
Currently the only fix is to use the GTN750 toolbar panel (the free version is enough) and use the import / import from ATC function in the filght plan page.

Exactly that is my problem: the 530 doesn’t come with a FPL on loading a flight unless I uninstalled the WT addon. With the 750 installed, it works as I experience it in every other aircraft.

Now it’s working properly. Thank you everyone!

1 Like

Hi all, just installed the BS Caravan after flying the BS King Air for over a year. Five flights in I’ve been unable to complete a flight due to “overstressing” the aircraft. I don’t see any notes here so it doesn’t appear to be a community issue so it looks like it’s me. I’m not overspeed in airspeed and the torque was well under limits and I’m straight and level when it’s happened twice, once in a climb and twice on a descent. I haven’t completed a real flight. Anyone got any hints? Thank!

Did you leave the storm window open? Ask me why I’d ask that, haha.

What was your indicated airspeed and altitude when it happened?

1 Like

lol…I remember hitting the button on the window of the Beech 18…done! 160 at 8,000. I think I’ve got a mod conflict. Turned off Aircraft Overstress Damage and on the next flight got a Battery Overtemp issue. Now starting to clear the Community Folder. No issues so far but it’s early! :slight_smile:

1 Like

I don’t follow what you mean about avionics folder? Yes I’ve only tried the BS C208 yes source is set correctly, (I tried both ways to be sure)

I mean avionics packages (last gtn750 and whatever gns530 if you use the pms50 one, if you use gns530 by WTT you must remove this gns530 folder depend on what you are using) to be sure it s not conflicting mods

(about the Rnav, it is meant to be used to display KNS80 VOR)

maybe should you try with the gns530 from market place (by WTT) (it s free) for FloSchulz90 it fixed the issue …

I did not tried on my end with pms50 gns530 to see if it present any issues, if I have time later I will maybe give it a try

1 Like

But only with the PMS750 as well. Just to be precise and not create further problems. :slight_smile:

1 Like

Ok yea i get u now, i currently have been using the pms avionics add-ons until recently when i removed them hopping to fix this issue, i will try the WTT avionics packages n see how i go, cheers for your thoughts

Can anybody here help.
I have recently purchased the steam gauge overhaul for the Caravan but, have an very annoying alarm when I turn on the battery power.
It persists even after aircraft start and nothing on the annunciator panel.
I have tried every switch, knob and button to stop it. The only way that I have found to stop it is by pulling the Bus 2/2 circuit breaker.
Can anybody give some thoughts on the issue.
Thanks in advance

Did you open the fuel valve’s at overhead (minimum one, better both )before turning the battery / avionics on?

1 Like

I have the same issue and it is resolved by pulling the fuel flow breaker. Doesn’t matter what order I go for fuel then battery, still get the alarm. I’ve reset all failures, from cold and dark, turn fuel to on and turn on the battery and the alarm immediately sounds.

yes, I did and does not help

That worked. I might put a ticket in to Black Square and see what happens.

1 Like

I only get the fuel warning once I switch on Avionics Bus 1.

No offense but you guys must be doing something wrong because I and many others don’t have this problem.

If you turn on the avionics without the fuel open, you will get an alarm, but if you open up the fuel first before you do anything, then you should not.

EDIT: When strange stuff like this happens it is worth taking the time to make sure there isn’t some odd keybinding screwing things up.

For example, with my Honeycomb Alpha MSFS by default binds the ALT switch to something in this plane that causes all sorts of problems unless I turn it on. Even though flipping the switch changes NOTHING visible in the cockpit. There is some system behind the scene in the simulation that is bound to that hardware switch and if I don’t turn it on, everything goes haywire.

1 Like

Not sure if this relates to all turboprops, but here’s my question: At higher altitudes, is it normal that I need to bring back the prop a bit right from the start? I’m at 8000 feet, power at 500, prop RPM already maxed out, barely climbing. So I lower the prop, add power, still some room on the ITT, and it’s climbing well agagin.

Is that how you do it? Can’t remeber anyone mention the prop in the “how to fly turboprops” videos.