Blurry Garmin hard buttons

I have a Pimax 8KX and the resolution an clearity is super in MSFS. :slight_smile: I can clearely read gauges and text, except for one issue, and that is Garmin devices.

On for example the G1000NXi, I can clearly read all text and symbology on the LCD screen, but the buttons for com and autopilot are very blurry. At first I thought it might be due to them beeing white text on black keys, and that lightbleed/god rays on the headset made them blurry. But, I can clearly read even smaller characters that are white on black on the LCD display, so that cannot be it. So i’m left puzzeled. Do the textures on the Garmin hardbuttons really have that low of a resolution compared to the rest of the cockpit?

I have tried to increase texture quality, super sampling etc, but nothing works. Still cannot read the letters on the Garmin hardbuttons.

As an example, on the below image I can clearly read the small “1” and “2” on the com display in VR (red circle,bearly visible on the picture, i know…), but all the text on the hardbuttons are a blurry mess (blue area).

image

Anybody else have this problem? Any solutions?

texture resolution set ultra?

I have the same problem with a G2 headset, even with Texture Resolution and Texture Synthesis set to ultra and Object LOD set at 200. The LCDS panels are sharp as a tack and easily readable sitting back, the buttons far from it.

Yup, tried to pull every slider I can think of to the max and still same problem.

But I see now that an admin (I presume) has changed my title to “Bug Logged”, so maybe this will be fixed in the future? Hope so! :grinning:

So, I guess is should vote for my own bug at least! :slight_smile:

I noticed that when using the Oculus quest 2

I have this same problem. I am using a Xbox series S and a Samsung 32 inch 2K screen. Makes the garmin impossiable to use zoomed out.