Boeing 787 Autopilot Not Tracking

Hmmm… I just completed a flight on the 787 and it works well for me. Seems that the 787 autopilot is fairly buggy for some though. Wish I could help more!

I’ve had the same problem with the 787. Tried a flight plan from Simbrief and it was the same as FP from the sim. Had to use AI to get it back on course. Also it missed the runway when landing by a lot. Strange, it appears there is several bugs in this autopilot.

Had exactly the same issue. As soon as I engaged the Autopilot, the plane took a steep dive to the right. Had to manually get it back by using AI. But it never followed the flight plan and missed the approach by a lot. Hope they fix these bugs, I like flying the 787

YOUR PROBLEM IS IN THE FLIGHT MODEL SECTION, I HAD THE SAME PROBLEM, SWITCH FROM REALISTIC TO MODERN, WITH THE UPDATE IT GOT SWITCHED SOMEHOW, BUT THAT IS WHERE THE PROBLEM LIES…
2021-09-13T06:00:00Z

To Iantzw1974: My Fight Model has only two options, “Modern” and “Legacy”. Mine has been on Modern the entire time and my G-3000 still does not track properly.

My 787 after take off engage AP and the plane turns left goes round in circles , any fixes thanks.

1 Like

Suggest to increase the deadzone on your joystick axis a lot for troubleshooting, or even disconnect it.

I have the same problem major problems,mine won’t intercept lnav…lnav in white in the flight annunciation but the plane flies where it wants really annoyed .

1 Like

Can not confirm it with the lnav problem. I load it via simbriwf, also departure and arrival with rwy and stars. It is important to execute the flpn.
Even vnav is working during approach. Only thing what happend to me is that on approach the plane goes crazy and not flying not ro the next waypoint so an approch is not possible.

1 Like

Have you tested with an unplugged joystick to rule out any hardware problems?

it was the deadzone. when i set all deadzones above 15 it started working. thanks for help

1 Like

Similar problem just started for me. I experience a track offset of several miles until well past the SID route. Then it goes back on track.

Also encountered an RNAV issue yesterday: RNAV27 LVP @ KEYW. Fly to IAF, push APPR for GP and the FMS defaults to non-existent ILS (LOC and G/S appears in PFD). Emptied Community folder, Uninstaller Orbx KEYW, etc. and re-flew 5 times with same result. Flew same approach with TBM and Carenado M20; captured RNAV LPV approach & GP with no issues. I’m curious if anyone else might encounter/confirm this issue with RNAV 27 KEYW??

I was usually under the impression that APPR can’t be used for RNAV. I always use a manual glide path descent angle once I passed the specific waypoint on the charts.

Roger! With RNAV there are different types of approaches (lateral, lateral+vertical, etc.) and they will be indicated on the applicable plate/chart. LPV in particular provides vertical guidance like ILS with lateral. Pressing the APPR on an ILS approach will reflect LOC G/S (Glide Slope) in the. PFD. On a RNAV LPV approach, G/P (Glide Path) will be shown.

I’m attaching a handy little reference I came across for a visual aid. Hope it is helpful!

3 Likes

I had the same issue and i dont know how to fix it

1 Like

I have also the same issue, aircraft banking to the left and not following either LNAV nor heading. Is the opinion still that this is a flight model option problem? Is it the same for the stable and dev. versions?

1 Like

Same issue to ight, heading from LAS to SFO.
Got out, jumped in A330-900 and flew perfect all the way!

Guess if its Boeing, I ain’t going!

I did a flight in it yesterday and I think the latest dev version has this sorted out. It is still a little buggy occasionally when switching from LNAV to heading mode and visa versa. I found the solution if the LNAV had trouble engaging was to simply enter “direct to” the next fix and then re enter the old fix back in. Overall the mod is working great for me now though

Same problem. Cannot switch from LNAV mode to CAP mode. The planes do not follow the course. Impossible to avoid thunderstorms … I cannot find the solution. And worse, I don’t know if it’s me doing things wrong or if it’s the system that’s bugged.

The solution is here