Bravo Throttle - Deadzone Issue


I am having an issue with my Bravo that when I move the Throttle, Prop, or Mixture I have to move over 50% before it registers anything, and when I pull back on them they go back to 50% only and I have to do the indent to get them to reset back to 0%.

I have looked at sensitivity, everything is working perfectly. I have tried to Game Controller Configuration in Windows its working perfectly, and I even loaded them up in xPlane and they worked perfectly in that sim… So it is a MSFS2020 issue and its with all planes, I was flying the Mooney and TBM with different profile configurations but same results.

Any ideas for me to try?


Just to double-check – some axes have both “-100 to 100%” and “0 to 100%” versions available to bind. Make sure you’re using the ones that either say “-100 to 100%” or don’t have a specific label, not the “0 to 100%” versions.

They say -100 to 100% well at least the mixture does…

I have just realized that when I go to configure a specific output, throttle 1 for example, that when I start moving the throttle lever that I am moving half way before any acknowledgement, so its like it is only calibrated from 50% to 100%… and 0 to 50% does nothing… When I go to sensitivity, it moves all 100% perfect… I just tried to rest to default my bravo in USB Controllers in Win10 (Fixed one guys similar issue) but that didn’t do anything.

Try clearing all the Bravo binds and then rebind the axis.

I am not sure how to do that unless you mean “clear the input” for each lever then rebind and validate.

If that is the case I have done that a 100 times. I even unplugged the brave, restarted msfs 2020, and the replugged it back and restarted again to see if it would assign as a new controller but it just detected what I already had setup.

I also ran into this exact problem, and what MalexPrime suggested fixed it for me. I had to clear basically every axis input, the Mixture, Prop Pitch and Throttle axes and then reassign them. Once I did that, everything worked fine. Notably, once they worked right they could be tested from the settings screen, you could see the axis moving correctly on that screen, I didn’t need to keep jumping in and out of the plane to test it.

I have no idea why it worked, but it did. If you haven’t tried it, clear all of them out completely, then start resetting them, and hopefully that fixes it for you.

I also had the same issue and had to rebind everything. Initially the axis had a + symbol after their name. I made sure to unplug any other throttles and controllers and then cleared all axis assignments and then did the rebinding and all is well. Good luck!

Boys, that did it… Removed all the bindings and re-binded and the magic came to life… Woooo, Thank you so much everyone :slight_smile:


Mine is just the opposite, the top 1/16th of an inch is 50% of the throttle, don’t remember how many times I have gone thru the rebinding process.

This time I will try the MalexPrime suggestion for Swervo and rebind everything in Power Management…

Rebinding did not fix the issue. 50% of my throttle is still in the top 1/16th inch.

But, the bravo throttle works just fine in xplane.

Any other suggestions?

You have to clear all bravo keybinds, not just in power management.

OK, before I do something that is going to ruin my day.

Go to Controls - M: Preset Manager - and use the X ‘clear all’ key bindings, then rebind?

Thank you for your assistance MalexPrime, I hope this does it.

I’m not sure how others have cleared them. I went in and removed each bind on my Bravo individually. Then I started with the throttle axis and bound it. There are two throttle binds, one that shows something like -100 to 100 Axis and one with just Axis. I ended up trying both until I found one that worked. I had to use the reverse check box.

Thank you for your response Malexprine.
I have tried several times and different settings, even setting up again and again with ‘Twin Engine Complex’ and deleting ‘Twin Engine Prop’ without a change in outcome. I also get the same results with a single engine config.

Hmm, I don’t think I had any profiles set up. I just started with the default and deleted everything from there. I’m not sure why it’s not working for you. A last resort would be to delete all the Bravo profiles like you suggested earlier, start from scratch. Beyond that, I don’t know.