Bug and Feature in one - Frame Generation in VR mirror view

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Have you disabled/removed all your mods and addons?


Brief description of the issue:

When in VR mirror view have FrameGeneration ON

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

It just happened, maybe after last update. My last recording was on 7th of May and fps was 30/45 as usual but now every time I switch to vr I have FG on in mirror view. Doesn’t matter if FG is ON or OFF in 2D options. In headset i have 45/30 fps with reprojection and in mirror view fps is doubled and can clearly see FG artifacts. It is very nice feature when I want to record video but when I am just flying it is wasting gpu resources. It would be nice to have switch in options to ON/OFF FG in vr mirror view.

Many issues may be due to an outdated graphics card. Please state your Graphics Card Driver Manufacturer (NVIDIA, Intel, AMD) and Version (Learn how to find your current graphics card driver version):

rtx4090 531.29

PC specs and/or peripheral set up if relevant:

HP g2

Build Version # when you first started experiencing this issue:

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video: