[BUG LOGGED] Cannot hear ATC instructions and other aircraft suddenly while AI copilot still responds

I’m getting this more and more since SU6. Before SU6 it would happen rarely, long into a flight or when going to a secondary destination without exiting back to the menu first.

Now it happens already after loading a flight

It tends to just stay there but I figured out that when you switch to ATIS (no sound, no text) and then back to clearance, at least the co-pilot starts talking more.

Without this ‘work around’ to activate the co-pilot (on ATC duties) I had to watch the ATC window for any options to pop up, like switch to new frequence or acknowledge to find out what ATC was supposed to say.

I filed another report with Zendesk, long standing bug, getting worse.

3 Likes

This is happening on just about every flight now. I really hope that they can sort it out soon.

3 Likes

Same problem here

1 Like

Same problem here with all updates.

1 Like

I did turn off Azure before the start of my last flight, and I had sound all the way through. I read that is the trick. You can’t change during a flight, but it seems to work OK if you do so before a flight, it seems to work OK. I’ll try again today.

2 Likes

This bug was only occasionally, now it is on every flight I do
I think the AIG add on mod overloads the ATC as there is so much more traffic involved taxiing , taking off, landing I just think the servers cannot cope with it and just switch off

I can hear my copilot read back , this happens about 20 minutes into a flight then silence, before that ATC is very active with all other traffic, it’s got to be fixed soon as it’s getting ridiculous

I can only use ATC in offline mode. When Azure is enabled it stops working after about 20 minutes.

Yes, that is my situation as well. Azure cuts out after about 20 minutes.

Same here. It breaks after some minutes. In my case usually after 10 - 20 minutes.

Like most of you, I also have encountered this annoying situation, but just recently I changed a setting which I believe fixed it.

I changed this setting in “Assistance Options” > and set it to “True to Life”. Now with this setting you will have to manually reply to each and every situation but the ATC audio has not failed yet and I’ve made at least 10 flights of over 2 or 3 hours each.

Just sayin’…hope it works for you too.

2 Likes

THanks for this. I’m having this issue every flight this past day or so. Will try your suggestion.

Thanks, I will try your suggestion, hope it works for me :pray:

You sir are a gentleman and a scholar

It worked superbly, thank you so much , as I have AIG installed it was brilliant

Sending you a couple of virtual :beers:
Cheers and thanks again

1 Like

You’re very welcome. I’m glad it worked for you.

Happy flying!

Why am I not seeing the true to life setting in the assistance options? I notice this problem occurs usually if you are handed off from one controller to another but the same frequency is ‘shared.’ For example, let’s say that you’re handed off to Seattle Center by Seattle Approach. Your copilot switches the radio but then you hear a pilot talk to approach on the same frequency. When that happens, no ATC although your copilot hears it and responds. It’s frustrating especially when you’re trying to approach an airport. I won’t go into details as to what happened to me today when both copilot and ATC went silent.

Same here. Seamed to work 3 days ago. I can barely hear the interaction, but barely audible.

I found this only happens when the copilot handles the radios for a while. Im not sure exactly how long but I have been able to turn it on for a min or two and turn it off without the bug happening. But whenever I leave it on for the cruise portion of a 2hr flight, the bug always happens. I also found out that it only affects the currently selected COM.

When doing a flight, I usually do ground/tower on COM1 with the departure frequency in COM2. Then once I take off and switch to departure on COM2, I set the copilot to handle radios. The bug happens and I leave it like this for cruise. Once I hear the copilot acknowledge the silent decent request, I turn off the ATC assistant and use COM1 (which still works fine) for the decent/tower/ground at my arrival. It’s a bit annoying but better than silent ATC for now.

2 Likes

Thanks. I appreciate it, @CaptainJoMomma .

Just here to say that I experience this bug as well