[BUG LOGGED] Elevator trim doesn't work as pre-SU5 and it's impossible to fly

This is how they treat all critical QoL issues right now, and it’s just getting depressing and far out :joy: You’ll notice the same treatment of QoL bugs introduced in SU5 regarding mouse cursor issues and joystick controls freezing when free-looking. Introduced in SU5, apparently “logged”, but then all subsequent hotfixes (I say all, but really… we’ve barely received any) end up fixing idiotic things like water masks in a lake, instead of actually doing something about the things that matter…


I found that both of these issues are related; at least for me, if a plane has bugged trim axis it usually have bugged trim buttons as well. I use both controls since SU5, so I can have some kind of trim capability when the axis is borked.

Also the World Updates, water masking, and any visual world changes are probably made by another ‘visual’ team, while the ‘core’ team is still working on this issue, as they commented above (at least I hope :smile:), it is just a big and/or risky bugfix. It’s frustrating to wait, but the last thing everyone wants is them releasing more untested code which break more stuff.

Putting aside possible issues with analogue controls and axis bindings, does anyone have a backup of the game content from prior to SU5?

I looked through the configs for the C152 and C172 as these are having a significant reaction to minor amounts of trim. There was one particular entry that caught my eye in the flight tuning section, elevator_trim_effectiveness. In the case of these two aircraft the values are higher than most aircraft which appear to be at the default value of 1. Whereas aircraft like the Icon and XCub appear to have had values reduced.

1 Like

Interesting, have you tried to play around with the values?

Yes, adjusting the values alters the behaviour as expected. What I’m more curious about though is if it was simply a change in these values with SU5 that is responsible for the increased sensitivity or if these values were already in place and something else changed.

On some aircraft (Icon A5) the trim works in the wrong direction. X52 thumb wheel. With the C172 everything is ok. Anyone have an idea?

yes it’s mixed up between all airplanes. You’re doomed if you don’t always fly the same plane

Make a copy of your controller profile and in this copy check the “inverted axis” box if you use an axis for the pitch trim, and/or invert buttons for pitch up/down if the buttons direction is the issue.
You can choose the correct profile before flight or even in flight if you forgot to do it before.
I know it’s not really satisfying, but it’s a workaround.

1 Like

Just to confirm, this reverse trim problem only occurs if you are not using buttons for trimming.

Wait, so is that really the extent of the 152/172 sensitivity issue? Ignoring the other button and axis issues people are having?

Like, If I ignore the button and try to set the trim just by clicking and dragging with the mouse, the nose will shoot up or down, whereas in the real plane you can move it a fair bit to make very minor trim adjustments.

If so, I’ll have to try modifying that value myself if possible and try it out… just want to use the c152/172 in a somewhat realistic way as I find it genuinely very difficult to hold altitude currently.

Especially the 152 trim is at least 50% too sensitive.
Suggest to reduce the effectiveness by ~75%.

1 Like

I’m trying to ascertain if it is simply a result of these values having been changed with SU5 or if it was soemthing else, be it another value or something deeper. That said, you can simply change the values to reduce the effectiveness of trim.

Currently (all values from memory so might be wrong) the C152 is set to a multiplier of 1.51 and the C172 has a multiplier of 1.33. The XCub is 0.33. When I tested the C172 with 0.33 trimming was obviously less sensitive and nicer to use but might be too far in the opposite direction. If you want to adjust the steam gauge version you’ll need to make a mod from the G1000 files rather than directly editing files due to the encryption.

This is in the flight_model.cfg file by the way.


Yes only with a trim axis named x on the x52 trottle

Back to FSX world: editing .cfg files to workaround the bugs… :neutral_face:

Reverting the catastrophic last update would be the wise choice

1 Like

Since the day after the release of SU5 this is the best solution.

Can you say exactly where this entry is found? I’ve been through all the .cfg files for the 172 and can’t find it.


My advice is don’t make changes to the config files (leave that to the propeller brains, patches could overwrite them:-) set the elevator trim axis to some axis like the top wheel on the X52 Pro throttle and ignore it, just make sure it is always centred before flying. It is still not working properly. Set elevator trim up and down to down and up on a hat button and use that. Since the last patch or two it is much better and even works well on the C172. I’ve tried it on the Nanwalek windy landing challenge and works well on my X52 Pro, same for the turboprops as well. Don’t use trim on the Airbus as it is fly by wire, it goes where you point the joystick, in theory.

IMO it’s way too sensitive on the 152.
A single trim click will change the vertical speed by 100-200ft/min.

This has nothing to do with FBW.
E.g. the 777 and 787 are also FBW aircraft, nevertheless you need to trim them IRL.
Unfortunately Asobo changed the 787 into an Airbus with SU3 and now you can’t trim it anymore :frowning:

We are over two months since this issue appeared, 259 votes and still no solution. Speechless.