[BUG LOGGED] Elevator trim doesn't work as pre-SU5 and it's impossible to fly

Working at last… let’s fly!

The trim wheel in the Cessna 172 Classic is finally working as it should. No more jumps, no annoying clicking noise and no coupling with the electronic trim. Very good Asobo. The trim with the saitek cessna trim wheel works perfectly again. I am happy :slight_smile:

when using an axis :
The only two planes I have with the trim reversed are payware ones :

  • JU52
  • JF PA28
    All the others have now a correct direction for down/up nose according to the axis

Hopefully, this will be patched sooner or later

Happy here too ! :slight_smile:

thanks for this clarification , i have the bravo , and the wheel behaviour on SU5 was great and is now poop again with SU6 , but have somewhat fixed it with help of FSUIPC.

posting this here as it might help someone . Asobo needs to differentiate between digital button trim , rotary encoder trim and axis trim in the future , otherwise there will be one fix that fixes it for one side and breaks for the other at the same time

I found it turned ok after su6!

Really hoped SU7 would solve the trim problems but trim is still broken.

About the trim issue, to me at least, the SU6 fixed most of it, but since that (since SU5 actually) some planes have their trim wheel inverted.

And it’s not only third part planes. Some Asobo planes also have the trim wheel inverted from most of the sim planes. And no, this still hasn’t been fixed/homogenized yet.

Trim is still inverted for almost every plane for me. Even on the new pilatus porter. Also I’m not able to trim a plane correctly. Either it shoots up like a rocket or it sinks lik the titanic.

1 Like

it seems to me,now the trim can work since it failed by su5! Su7 has fixed my others problems like: A5 GPS dark screen, airliner wont follow nav if i didnt first choose fly it when msfs started!
DX12 work well too.
SOfar as i can say: Just one defect: Replay need to be perfect and easy to use for simmers !

After every last update I have to reverse my trim wheel axe in the settings for some planes:)))

Still not working… it’s not possible to fly with the trim always jumping…

Hi all,
I am new to the community and sorry if I am not doing very well addressing you in this thread.
I need help. The problem I have is that when trying to correct the pitch of the plane with the trim, with the switch or compensation wheel. The trim apparently moves and corrects while you are giving it, but as soon as I stop giving the wheel, it returns to the position it had and loses the configuration that I have set.
I have tested it on various aircraft, cessna 172, cessna Citation Longitude, Boeing 787-10 Go and it works poorly on all.
I hope your help to see if I can solve it.
Thank you so much

Perhaps you need to disable auto-trim in assistance options.

1 Like

Thank you very much for your help. Problem solved…

Guys, i had the same ■■■■. Look very very thoroughly on your mappings. I saw it after the 4th time and i thought all mappings are correct. I had a double mapping what cause this issue. The trim works fine.

Fixed in version - Sim Update 6