[BUG LOGGED] "Legacy" mode when interacting with cockpit instruments/switches got nerfed

Been playing since release and let me tell you that the Xbox-ification of Sim Update 5 is terrible.

The new, default “lock” mode is seemingly broken because nothing happens when using a mouse. Not sure what I’m missing because no mouse button does anything. Anyway, first thing I did was returning to the “legacy” mode, but the old tooltips that appeared when you moused over an instrument are gone.

Example: I used to be able to see throttle, mixture, propeller percentages while dragging the levers. Not anymore, no matter what settings I enable in the options menu.

For some 3-way switches like fuel pumps and such it’s the same thing. The pop-up tooltip is now giant but doesn’t tell you anything.

Is it a mix-match of different accessibility settings or are the old tooltips really gone for good?

I agree this is a terrible step backwards. This has got too be fixed quickly or too many of us are going to be in a lousy mood… :frowning_face: :frowning_face: :frowning_face:

24 Likes

I have a feeling that for the consistency sake and product launch/update sake they did this together w/ Xbox and will eventually start fine tuning the PC version accordingly. That’s the hope anyways.

3 Likes

It’s heartbreaking because I really thought this was going to be IT. The one update that got me the only thing missing from my sim install so far: proper multi-core and good performance. The rest was already oh so very close.

I really didn’t take into account the devs “dumbing down” something as essential as the tooltips. I don’t have a HOTAS and I rely on the tooltips a lot to get a better idea of lever and switch positioning.

6 Likes

image image image

4 Likes

Yeah, it’s a fiasco. I’ve been using MSFS2020 since day one, and the product we got today after this update is not an improvement save for one issue, which is major. Otherwise, what a mess. The product feels dumbed down and less stable.

  • My default controller settings were stripped and could not be retrieved. Had to build out the controller settings from scratch. Back to flying from the keyboard for now.

  • Can no longer control the aircraft and adjust settings with the mouse at the same time. If you’re trying to adjust the weather or time, and you have to pitch left for a moment, the mouse cursor disappears. Prior to this update, the keyboard, mouse and controller worked together like a symphony. Now they override one another.

  • You can no longer adjust the time minute-by-minute. The slider is smaller and adjusts in 15-20 minute increments. Want to catch that sunset you just experienced a minute ago? Now you have to go back ten minutes and wait for it. I’d love to know how this change got approved. Unbelievable.

  • Free flight mode loads about half the time. The other half of the time, the sim freezes and I have to force close and restart everything. I could always rely on my flights loading. Now it’s a coin toss.

  • One improvement, and it’s a big one. I’m getting better performance across the board.

22 Likes

No need to go back to legacy mode, there are new mouse actions that you need to assign to get the mouse interactions back (they will also show up in the tooltips)

12 Likes

In the new “lock” mode the mouse is useless. The humongous tooltip asks me to press [?] to interact, which sadly is not the question mark key (I tried). As I see it, even if it worked it’s going to require an extra key or extra click while before it was just simply clicking-dragging. I don’t see how “lock” mode is an improvement for us PC users.

In legacy mode nothing shows up while it did before.

4 Likes

Okay, this sort of makes sense but at the same time it doesn’t. So they made the “lock” mode the default but without binding it to anything? That’s sure to make a lot of people happy /s.

Can we at least get an option to get the minimalistic tooltips back?

5 Likes

Go to options > controls options > mouse
select default profile and save changes
image

5 Likes

This is an user interface nightmare. It has 2 different sets of unnecessary, duplicated information, it obscures several other instruments and doesn’t accomplish anything more than the old, minimalistic tooltips:

Two different sections telling me to press/click. Name of the instrument/switch repeated for no reason. We only need the two parts in green, the rest is visual pollution.

Could you imagine if Windows had such tooltips?:

48 Likes

You made my day :rofl:

2 Likes

Asobo shouldnt have forced the console UI on PC. I really would like the old minimalized tooltips back. Even if you keep the new minimal tooltips they’re quite huge and spawn a blue eye when not entirely in focus.

“Legacy” UI/accessibility is some half assed attempt if i have ever seen one.

(voted)

24 Likes

This is it in a nutshell.

Duplicated information.

It’s as if Asobo have never heard of usability testing.

But…sadly I can actually see Windows going this direction. In many ways it feels like it has been going that direction for a while so I’m sure this new UI has received much praise at Microsoft central.

4 Likes

What the he!! happened? Mouse isn’t working on any switches or anything in the airplane!!…Yeah, I’m on an expensive computer so I can run this sim, so get your heads out of your Xbox!…And, this is what I have received for an update? Doesn’t a software company test their updates anymore? Com’on Asobo get it together!!

10 Likes

It’s telling you whether the item is a button or a switch/knob/… on the left and how to perform the respective interaction on the right. It makes sense and conveys two slightly different pieces of information. Maybe you should calm down from the “grr-change-is-bad” phase before evaluating it.

1 Like

That windows start menu popup comment is so funny. I couldn’t stop laughing

3 Likes

I still can’t figure out how to interact with the virtual cockpit with the mouse using this new UI.

1 Like

Legacy cockpit interaction setting works, however the tooltips are now not interactive. It used to state the action of the switch button, lever, knob, etc. for example it showed it the switch will be flipped to “off” or “auto”, no longer the case, now just tell you the name of the switch.

5 Likes

Well at least I know its not just me or something I did… C172 is useless now. Wont cold start, can’t change fuel selector to both, trim wheel goes from 0% to 50% to 100%… nothing in between. Even though in the trim wheel settings the potentiometer of my hardware seems to be working just fine with gradual changes, but in the cockpit my trim wheel nor my mouse interaction work…

2 Likes