[BUG LOGGED] Mouse cursor went back to the top left corner when moving around (translation) in the cockpit

agree this one is incredibly annoying, i wanted to write a post but i saw one allready so here is my vote mate

2 Likes

I still have the issue it is really annoying especially when you are trying to land in bad weather. Lot of things to keep up with and the mouse should not be one of them. Here is my vote.

2 Likes

This also happens to me, +1. It’s moderately annoying too because sometimes the mouse doesn’t even come back.

If you’re going to reposition the mouse after translating the cockpit camera, at the very least put it in the middle, not the top left corner!

3 Likes

So frustrating, sim almost unplayable now.
Since update 5 mouse cursor moves to top left when changing views with any of Hatswitch, Xbox controller or keyboard.

1 Like

This is a really annoying issue and kills the immersion during struggle to find your cursor. I hope it will not be ignored. Please consider this in your upcoming hotfixes.

Kind regards.

1 Like

They marked again the ticket as solved, but no answer or anything. I don’t know if that means that the fix is already corrected (wich is not) or that the fix is corrected and addressed to be released in the next update.

I think there should be better understanding of what the feedback of Zendesk actually means.

1 Like

It’s weird closing a ticket without any note as solved. Let’s wait and see in the upcoming hot fix and devolopment update notes in case it’ll be sorted out with world update. It’s an important bug and I dont want to see this as ignored by Asobo. I’m sure they’ll do their job.

Kind regards.

1 Like

Bug still present after hotfix. Submited to Zendesk because they marked it as solved (and I wanted to wait in order to see if MAYBE it’s solved in the hotfix)

1 Like

Same stuff for me. Let’s see if 2nd hotfix fixes this

1 Like

I hope they solve this out with WU6 because it really makes flying harder. I tried setting all keyboard and mouse settings to default but no chance. Bug still there even after clean reinstall of Windows and MSFS.

1 Like

Hello, thank you for this feedback. I’ve been able to reproduce the behavior, let’s hope it will be easy to squeeze it into an update soon.

7 Likes

You will probalby never get feedback on any ticket you open there. I never have …

They will usually just close it.

I have the same issue when using my coolie hat (assigned to COCKPIT LOOK commands).

It works when I use the mouse to rotate the view by holding the right mouse button (assigned to TOGGLE COCKPIT VIEW FREELOCK (HOLD)). The axis of the mouse are assigned to COCKPIT LOOK UP, RIGHT, LEFT; DOWN (LOCKABLE) respectively.

1 Like

Same issue here. Still waiting a fix for this. It is one of the most annoying issues right now. I hope developers find it and release a fix for it :pleading_face:

2 Likes

Hope this gets fixed. I guess I am a non-standard user in that I fly with a mouse yoke. This said, every time I tried to shift my view with the arrow keys, it plants my mouse to the corner, which means hard nose down and hard left bank :rofl:.

1 Like

Happens here but whenever the cursor disappears, I use any of the up>down>left>right arrows and cursor returns. If using escape, need the mouse to return to game which isn’t possible if it’s hidden. Used to be able to hit esc again to resume but not any more. Try the arrows and see if your cursor returns. It’s been my only workaround.

1 Like

I think now the “P” key is the default one to resume the game after hitting ESC. This works for me. But the thing is that if you go the ESC menu, when you return in some aircrafts the flaps are fully extended xD

2 Likes

Good to know. Thanks :+1:

1 Like

Just one update to my previous comment. I found the solution to the flaps issue. Link here:

So now I can use again the ESC menu as a workaround until the mouse fix arrives :wink:

2 Likes

I do have them both and the rudder pedals too. I fly the FBW 320 almost exclusively these days because it’s a fantastic aircraft.
Will delete those tomorrow. I was half suspecting something like this and now it’s confirmed!
Great tip. Much appreciated :+1:

1 Like

Did anyone try this issue out after WU 6 ?

As far as I see no information is shared in particular by release notes.

I’am curious to hear from you… (Unable currently to update on my own PC)

Kind regards