[BUG LOGGED] No AI Buildings anymore! :/

Since SU5, especially in VR, I don’t get 3D buildings anymore. Just flat satellite images.
This happens for example in the LSZH area when you fly close to the airport to north, north-east or north-west.
Thing is: initially, in the area where you start the flight (from runway or directly in the air), the AI buildings are there.
But as soon as you fly a little bit away from that initial radius, you will soon see lots of areas/villages with no buildings at all. Just flat satellite image.
Especially in VR. But maybe also in 2D mode.

I created a video to show it:

Just terrible. Does anyone else also having this and maybe even a solution?
I hope Asobo will fix this soon.
SimUpdate 5 is just such a mess :confused:

Yes. I was getting no terminal and autogen building at all after the SU5 update and a few CTDs to go with it. I’m sorry to say but the only thing that fixed it was a full reinstall, but it is now working sweet, SU5 graphical ugliness issues not withstanding.

A follow-up video to further illustrate the issue and it’s behaviour.
Asobo: Please watch it! Thank you

Hi @TheRealOli4D this is most annoying! Voted.

I get the same in London, autogen appears where you start but fly a few miles and all the autogen buildings become (outside the photogrammetry city) more sparce until the terrain is completely flat.

Changing the building graphics options does bring back the buildings again but only for that local area, fly to a new area and poof they are gone. The sim simply isn’t reloading autogen buildings when you fly over in VR.

This has ruined my experience in VR which is such a shame. I had thought this might have been fixed as I did a desktop flight and all was fine. But this seems specific to VR. My terrain and building settings are ‘200’, but that’s clearly not an issue as something should show up even if it’s ‘0’.

1 Like

I’m seeing this as well! No VR, but TrackIR. An uneducated guess: some kind issues with LOD and loading of autogen, which increases the more you pan the view around. Hence, happens more to users using VR/TrackIR. :man_shrugging:

Did a flight without TrackIR, and could not notice the issues then.

1 Like

Thanks guys. “Glad” to hear I’m not the only one. Seems to be a wide spread issue then.
Please report it to Zendesk!
https://flightsimulator.zendesk.com/hc/en-us/requests/new
It’s important that this issue gets reported there incl. your system specs and all that.

One YouTube video showed that when you start your flight, even though your settings are Ultra the flight sim doesn’t render in Ultra. He had to switch to Low, save, then switch back to Ultra and it would load the right graphics. This has to be done every flight. Of course he wasn’t in VR but it seems to be relevant to this situation.

A possible fix/work around: Seems like there is a work around: Can someone confirm or deny this one ? For UK mostly - #23 by TidalPopcorn618

Looks like an issue with Procedural Buildings in the World Updates.

I guess I was naive but I really hoped they would fix this game breaking bug with World Update 6…
But nope… still the same sh&t…
Fly a few miles in Switzerland, Germany or many other places and all AI Buildings are gone.
Unbelievable.

I’m facing the same problem in Dublin - no AI buildings in large chunks of the city, only low res orthos.

Please see here

Have you tried to set the new “offscreen pre caching option” in the VR graphics settings to “Ultra”?
Seems to help… but I’m not 100% sure yet. Have not tested it enough.

Ya, it’s on ultra but that doesn’t help in getting the missing AI autogen back in Dublin unfortunately.