[BUG LOGGED] Performance Decrease when Using Pop-Out Panels

It likely wouldn’t considering the top bugs on their roadmap list have been acknowledged since the alpha and are still unaddressed.

That acknowledgement is akin to a wealthy person driving into an inner city ghetto, looking at the first person he sees saying “Wow. You really are living in horrible poverty.” Then proceeds to light his cigar with a $100 bill…

1 Like

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting. Persistent with and without mods

Are you using Developer Mode or made changes in it? NO

Brief description of the issue: Any windows that you can pop out and move to a second monitor (ATC, Map, G1000, G3X) cause a > 50% drop in frame rates.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered: ALT - Click G1000 Window , or pop out any of the standard windows (VR Map, ATC, etc)

PC specs for those who want to assist (if not entered in your profile) 1080Ti , 1440p monitor, 3900x 32g ram. 45 - 50 FSP typically in non-high dense populated areas with custom settings.

Did you submit this to Zendesk? If so, what is your ticket #? Not Yet, checking if this is a localized issue or not.

Okay, forum filled out;

Since the last update, I can not pop-out any windows to the second monitor. I get an instant 50-60% drop in frame rates. Before, zero impact. I am not sure if this is an issue specific to ME or something with this update but sure feels update-related. The stuttering problem everyone else is having I am also having.

This occurs with our without mods. My GPU utilization drops to almost nothing with a pop-out window:

Photos:

No - Popout:

G1000 Pop Out:

FVR Map Pop OUt in Both Modes:


GPU Performance:

I’ve been working through this issue for a few days, and looks like its “mostly” solved.

I found a post on poor VR performance and fixes and gave that a shot. Turns out turning off Game Mode and Turning Off Hardware Accelerated GPU Scheduling greatly improved this issue.

Now I sit with a ~15 - 20fps penality vs dropping down to 10fps. Before there was <10fps hit when doing this, so something HAS changed, but at least now it’s flyable. I’ve never messed with these settings so I don’t know if MS Windows turned them on, or if now MSFS can’t run with these on. Hard to say for sure.

image
image

Performance Now:

the latest windows update brought back HAGS issues… I still can not recommend to use this.

also… if you check your GPU load, be sure you check the correct values with the correct Taskmanager settings. See:

Apparently so… Doesn’t help stuttering at all, but made quite the difference with this issue.

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
Removed for testing, no change in problem behavior.

Are you using Developer Mode or made changes in it?
Using it for FPS view. When closing, no change in behavior.

Brief description of the issue:
I’m actually getting far worse performance now, post 1.14.6.0.

I’ve ensured I’m running 1.14.6.0, and community folder empty. Cache deleted (I dont use it anyway).

I used to get 45-50 fps with the High preset with most GA aircraft, in photogrammetry areas. Now I get 25-30 fps in the same areas. Even in the middle of nowhere Wyoming, I cant get above 30fps.

With the FlybyWire A320NX, I could expect previously around 30 fps. Now I’m getting 12-15.

Something is seriously wrong here. No clue how to fix it. Mainthread/GPU is getting hammered.

UPDATE: I’ve found that when any window is popped out, as I’ve always flown with ATC on the second monitor, it tanks my framerate (from 55-60 to 25-30). If I close the ATC window, or pop it back to my main monitor, framerate instantly goes back to 55-60.

Disabling VSync in game has a similar effect. FPS go from 25-30 up to 40-50, but not quite as high as simply closing the ATC window.

SECOND UPDATE:
I re-enabled “Hybrid Mode” in Lenovo’s Vantage Software, and although this is supposed to be for intelligent switching on battery power, it seems to have cured the issue. Beyond Bizarre. I’ve had this disabled from day one, and now it becomes an issue apparently. I’m guessing that it disabled the integrated graphics card, which…maybe handled the ATC window when on the second monitor, so now the Nvidia GPU had to do double duty? Not sure if that’s how it works.

But…I’m now seeing high framerates again. Will update if things change.

UPDATE #3 - problem has returned. So I guess the ‘Hybrid Mode’ change did not fix it.

Provide Screenshot(s)/video(s) of the issue encountered:
With ATC window on second monitor:

With ATC window “popped in” to game.

Detail steps to reproduce the issue encountered:
Fly in any aircraft, in any region.

PC specs for those who want to assist (if not entered in your profile)
i7-10750 6-core CPU, 32 GB DDR4 ram, and Nvidia RTX 2060 GPU with 6bg of memory. Two 1TB M.2 NVMe SSDs. Windows 10 is at 20H2 update, Nvidia 461.92.

Did you submit this to Zendesk? If so, what is your ticket #?
I’ve never had any positive experience, or resolution of any of the problems which I’ve submitted to Zendesk, so no, I’ve not filed a report.

So frustrating…

1 Like

This doesn’t happen when using another program e.g chrome,Spotify etc. Only when opening the displays with right alt. Anyone else getting this?

may be because what we discussed here:

happens in your case too and so, because of limit the fps to a v-sync step, the GPU is no longer in full load.

If you have VSync on in sim, it will mess with you in all kinds of ways when you undock any panel or instrument.

1 Like

Actually, disabling v sync did nothing and in fact my fps and gpu usage are now going down in the cockpit and they weren’t before. Also this morning I did a flight with windows out and had no issues full gpu usage…

Hi,
If this is not the right place to open this topic my apologies.
I notice since the latest update when I pop the panels to drag them to a tablet my frames goes from 40 to 15 FPS.
Anyone encountered this issue for any chance?

My specs are

I9 10900k @4.9 GHz
RTX 3080
32 GB ram @ 3600 MHz

1 Like

I have encountered this issue. I think they know at least a bit about it, because in the dev updates they say they will address “multiple screens functionality” with sim update four, if my memory serves. I’m not sure if they specifically mean performance, but that’s what I’m hoping for as this issue is pretty annoying.
Also, its only been from the latest update for you? I’ve always had this issue but then again, you have much better specs than me so I’m not sure. Hope they can fix this!
Cheers.

I had this issue before,pretty much since the beginning to be honest.
Then for the last week or so was working fine,even the day I did the update I did a flight and was working good but last night I went to do another flight and the frames drop to 15 immediately.
This is very hard to understand,one day works good with a loss of maybe 5 FPS and now drops straight down to 15.
I even tried with the crj where I wasn’t having any issues at all and same thing,I haven’t changed any settings.
I’m lost when it comes to this.

Hi, im running a few displays, when I popout my PFD and ND and drag them to another monitor its halves my FPS from 40 to 20?, im using NVIDIA RTX2070 super, I dont recall this happening before? are there any fixes or will I have to live with it for now…I have vsync off and all monitor frq are the same.

thanks for any help!

Yep. The ATC Window, like the VFR Window, both are buggy. A well known fact for a long time. Both have my Com crash to desktop if I try to move either window. I get a friendly note telling me that the Graphics driver timed out {AMD}.

Not moving, or resizing, the Windows and everything is just fine. The game itself runs great on my Comp. Does anyone have a solution? I definitely have the latest AMD Driver; so this is not the problem.

No, this is not a new Bug Report, just a friendly plea for suggestions.

Hello
I have the same problem. If you open the ATC window on the same monitor, the frame rate is ok. If you then open the window on a second Montor, it collapses. For me this is 10 fps with version 1.15.10.0.
Greetings from Germany

That would be great!
My only other idea was if it were possible to edit aircraft configs to stop the sim from drawing the screens to the 3d cockpit , complete theory on my part I don’t know if it’s possible and that the popouts are linked .
In the a320 I turn off the FO’s displays but if you turn off the PIC screen it also powers down the popouts on my fourth monitor

I just discovered this as well. I have only one monitor; if the ATC window is off or popped somewhere on the screen, the frame rate is ok, if I pin it to the corner of my screen using the middle of the upper right window sizing icons (the open box with the arrow), I lose about 10 FPS.

Edit; just discovered by searching further this is not a true frame rate issue, but just a peculiarity as to how frame rate reported values are calculated. The number depends on how any extra windows are displayed. But it’s good to know that if you are trying different game settings, the manner in which windows are displayed skews the frame rate reported value.

Hi prior to latest update I was averaging 25 to 30 fps with a320 panels popped out onto 2nd monitor …since yesterday it’s now a steady unflyable 10 frames …

Has anyone any ideas what this latest update has altered to make this game …because its fast not becoming a simulation of anything for me.

I have wasted so many hours trying to get things simply ok…its become more that simple frustration. Any advice from anyone who knows wghats going on re the panel popout issue would be welcome.

Cheers
Harry