[BUG LOGGED] Sim intermittently freezes with Reverb G2 since last hotfix

Same issue here aswell as described by the threadauthor.

Hardware:
RTX 3080Ti
2x16 GB Corsair Vengance 3200 DDR4
Win 10 Ultimate
Ryzen 7 5800X
X570 Gigabyte Board.

OOh, this issue is growing and it is actually re-assuring to know we are not alone.
One thing that has come to light in the VRFlightSimGuy discord group is that those of us on the MS-Store version of MSFS 2020 are experiencing this phenomenon but, so far, those on the Steam VR version say they are not. Can you guys confirm which version you are on to see if we can narrow this down a bit more?

Microsoft, I hope you are reading this because if it is only the MS-Store version then there is something going wrong with the windows mixed reality portal / MSFS 2020 connection.

1 Like

Using the ms store Version aswell. Happens with and without addons in the community folder.

To add to my first post. As far as I can remember I havent had these issues with m previous 2080ti. That could be a coincidence or this issue is related with the rtx3000 series.

For me the issue is somewhat reproduceable when I approach an airport and the ground vehicles are loaded and visible and the New ground textures are loaded in. But sometimes it just happens randomly.

It feels like some loading process is wrecking the game. Is there a way to see if sth. Is logged? Or what causes these freezes?

Add to that that I sometimes have to freezes in pancake Mode aswell but a lot less severe and shorter.

Newest Nvidia drivers did not fix the issue either.

GPU Temps, Hotspots etc. Are all Well in their Limits.

Yup that sounds about right. It does seem to be a loading issue when approaching airports or transiting scenery areas. But as you say sometimes there is no rhyme nor reason. It even happens when you are sitting stationary on the ground and doing nothing at all. I do notice especially in the A320 NX it also causes the speed brake to be re-set with a clunk and also does strange stuff in the MkIX Spit. Like you say HWinfo64 reports no adverse reading on anything. It must be software related and Asobo need to address it urgently as it seems to be all Microsoft related if the Steam version does not experience it.

1 Like

Do you have another GPU on hand that is not an RTX30XX series card to see if it happens with another card or not? Just an idea. Or do you know of others with non rtx 30 series cars that have the same issues.

EDIT: I think it might be a RAM related issue. For whatever reason my XMP profile got shot out of the settings in the BIOS. I reactivated the XMP profile for my RAM and now the freezes still happen but A LOT less long and heavy. Something still is not right but I will run a memtest over night. @markymarksti I saw you use the Corsair Vengance LPX 3200 RAM aswell. Maybe @OSalvadorO uses it aswell? Maybe this is the cause of our issues?

EDIT 2: I ran the desktop version of MEMTEST and had no issues over night. I will run another Memtest86 run the coming night. If there are no errors again, I can rule out it being a RAM issue. Fun fact I had freezes in BF4 aswell the other day. Something sure is odd. Do you guys use rBAR on?

Don’t think it’s a memory issue. I too have run all the tests and all passed with no issues.
If there were memory issues they would also show up in other programs.

Resizable Bar is - On.

Still pretty sure its a software issue somehow and still to hear from any steam users experiencing the same issue.

Ok.

I personally think that it is some sort of issue when vram usage is very high. But you have a 3090 so that should not be an issue there.

Any other ideas?

Again could be but I can’t help thinking that this Steam vs. MS-store version may be significant.

Bios Update, Windows 11 upgrade, CPU boost All Cores…much better.
So far only 3 small blackouts approaching Heathrow but to be expected as it is one of the most resource hungry areas.

Float plane trip around Mauritius for 1 hour only 1 small partial blackout.

Will test further.

1 Like

On reflection after further testing at various locations…No Change :frowning_face: :frowning_face: :frowning_face:

Update from my side. Same issue also happen in pancake mode.

What helped me A LOT was to manually set “OffscreenTerrainPreCaching” to 0 in the usercfg file. If I have freezes in VR now they are A LOT shorter and I can (for now) continue flying after just 1 to 3 seconds.

I have the feeling this might be a driverissue from NV or some sort of VRAM allocation problem or loading problem. The heaviest black screens happen when I am on the final approach to any airport. GPUZ shows me that my GPU usage is dropping from 99% to 0%, while VRAM used doesnt change at all. As soon as the freeze stops the GPU jumps back to 99% usage.

I get this on almost every flight with my G2, usually early into it, first 5 mins, and always only once. The duration of the freeze varies between 5 seconds and 60 or so.

I use the steam edition of FS, so it happens there too.

Core i7-6700k
3090 w/latest drivers
64 gb of ram (xmp)

I have a replacement v2 cable on order from HP Canada, but have been waiting weeks for it now, no idea when it will arrive. Hoping that fixes it.

1 Like

One thing I observed is that the more I reduce the amount of workers, planes on ground and vehicles on ground on airports and deactive grass and bushes I get a lot less harsh and heavy freezes.

I really think it has to do sth with streaming/loading new gfxdata into the picture which causes the mayhem

Bang goes the Steam VR theory.

I think you are right about airport activity but it also happens at 37,000 feet when nothing has changed!

Hopefully, eventually, ASOBO will find a way to optimise the VR part of the SIM to utilise the available resources we have to produce a more efficient and smooth running system.

1 Like

SOLUTION/FIX

I can not believe that I actually found the problem. I just did 30 minutes of flying over Vienna (LOWW addon airport aswell) without a single freeze. Also no freezes in pancake mode. It is not a GPU related issue, nor RAM. It is a Reverb G2 USB power/connectivity issue.

How to check if you have the same error:
Go to your “devices manager/geräte manager” → Observe if the list refreshes multiple times in random timegaps
If it does open the dropdown menu “audio, video and gamecontroller” inside the device manager.
In there you should see an entry called “Realtek USB2.0 Audio” (you see it when your Reverb G2 is connected). If not wait until the next refresh it should pop up again.

If this happens you have the same issue as I had.

This is the “audio” of the Reverb G2. I always had the suspicion it could be sth. USB related as it is a known cause for FS2020 freezes, but never had that parameter in sight as I focused on the connected USB device list.

I then discovered that at every refresh the “Realtek USB2.0 Audio” disconnected and then reconnected. (visible and not visible in the list)

ONLY when I then decided to plug the G2 into my externally powered USB3.0 Hub (which I bought some time age as the G1 ran better with that aswell) the connection was stable and ALL refreshing inside the device manager stopped. This is the fix.

So in short - If you have the same connecting/disconnecting and refreshing in the device manager as I had make sure to CONNECT THE Reverb G2 to a externally powered USB 3.0 hub or try to find a usb 3.0 port on your mainboard that gives a 100% stable connection that stops the device manager refreshing.

I hope this solution is clear to understand.

@markymarksti @Ramasurinen @gosub4000 @KennyKanada @OSalvadorO

Yes!, I was experiencing the same and I started playing with different USB hubs and I found the 2080TI has a USB port as well, I plugged the G2 in that USB port and the blackouts dissapeared! It seems that the video card current is stable!

Well spotted!

1 Like

Yes the RTX2080Ti has its own usbc. Sadly my 3080ti not. But whoever has a usbc outlet on there gpu should try it aswell.

OK,

At long last I have got to the bottom of my issue.

As I said all along, nothing to do with hardware.

In the end it was simple…lighting.

I added more bright lighting above/around my rig and no more blackouts…Not One!

It was an issue flagged early on when the G2 released but I never experienced any problems.

What is happening in MSFS is it is periodically losing tracking which manifests itself as a hang/blackout.

I now have zero issues HOORAH!!

yes, I do have the maddening screen halt; see my latest YT vid at the bridge as I tank up to fight the
a NeoPad Fire mission in W. Los Angeles …during the water re-supplys at the bridge, there are huge halts, seconds in duration…is this the type of “freeze”/halt you are talking about? see SBS-3D MSFS H145 B5b 127 NeoFly Firefighting Mission Near L.A. - YouTube There are at least ten or more in the whole video.

…I was following the VR Flight Sim Guy’s recommended “configuration “route., but I definitely have the G2 connected to a 3.0 hub via the G2 Included USB 3 to USB C adaptor. My setup hides my PC in an enclosure, and I am loath to pull it out again…but…to solve this problem, I’ll (god I miss/hate IOS typing correction ) test my MoBo USB C connection…it was flakey before, thus the move to a hub. I’ll keep you posted.
Chas

Same problem and changing different usb ports don’t help. I am with the new cable v2 (reverb g2) and same freezes even when loading and the VR is connected but not in vR mode. The GPU goes to 0% then it recovers in some time.
I made this last week 2 flights 2 hours each in vR without any issue. What changed? WMR update and OpenXR. I cannot think about anything more, but deactivating OpenXR still is the same.

I had to change my cable 3 times. When I was in DCS, I never had any problem but all changes came after using it in MSFS. I think there is something inside MSFS that overload the Reverb G2 anyhow… because again problems after using the SIM.