[BUG LOGGED] TCA Quadrant & AddOn problem with SU5

I have the same issue with mine as well… i went into the controller settings and validated the 3 button which is the engine master switch… it worked once but after a sim restart it was back to not working again… not entirely sure how to fix that one… its the only switch for me that doesn’t work…

Look for Toggle Engine / Fuel Flow and remove it from the binding. The engine switches should only use the SET, not Toggle…

1 Like

Thanks for that, ill give it a go
So i understand…remove TOGGLE command and replace with SET Engine/Fuel Flow…is that correct?

well, by default the SET Engine Fuel Valve should already be bound.

Just try removing the TOGGLE command first, and see if it fixed the problem for you.

1 Like

I have the same issue!

source: Reported Issues - FlyByWire Simulations Guides

7 Likes

I have also the Thrusmaster TCA Throttle plus Addons.
Only Axis are work, Buttons are not responding.
Testing it in other games and there it worked fine.
I hope the hotfix will bring the solution

1 Like

Same issue as all the others in this thread. So why isn’t this listed in Known Issues? And will the Hot Fix on 7/30 fix it?

You have to wonder why they don’t quality test using what is a popular controller. Perhaps the objective was to get this out to xBox users and worry about quality control issues later.

“■■■■ the torpedoes, full speed ahead!”

1 Like

I also have the same TCA Throttle plus addons. My buttons are fine though. I can still use Autobrake, landing gear, engine modes…

But I need to delete my previous profile, then duplicate another from the current default profile, then remove the toggle fuel valve, as well as the spoilers axis, to use the Virtual buttons so I can use the spoiler lever to arm the autospoiler without conflicting with the spoilers axis…

Same thing happening here. Never got Engine 1 switch to work with TCA Quadrant throttle.

This has been answered 5 posts above you…

for me there is also another problem …every 20 sec i have a control freeze for about 10 seconds…

1 Like

Just downloaded hotfix and our problem has not yet been addressed.

1 Like

Can confirm the issue has not been fixed since today’s hot fix. Annoying!

Kind of Standard reply From the Support

German below

Thank you for contacting us regarding your concern.

In that case, I’d bite you to completely uninstall and then reinstall the driver.
Then download the latest drivers “Drivers - Package 2020_TFHT_5 + Firmware” from our support page and install them:
https://support.thrustmaster.com/de/product/tca-quadrant-airbus-edition-de/

Please also update the firmware of the product now:

If you have any questions about the update, please have a look at the following recording:

Now please test the device in the Windows operating system as follows:

  1. Press the “Windows” key + “R” key
  2. Enter “joy.cpl” and click “OK”
  3. When the device is recognized, go to “Properties”
  4. Test all functions of the device.

Please do not hesitate to let us know if these instructions have not solved your problem.

Kind regards
_-------------

Danke dass Sie uns hinsichtlich Ihres Anliegens kontaktiert haben.

In diesem Fall würde ich Sie bitten, den Treiber komplett deinstallieren und neu zu installieren.
Danach laden Sie die aktuellsten Treiber „Drivers - Package 2020_TFHT_5 + Firmware“ von unserer Supportseite runter und installieren diese:
https://support.thrustmaster.com/de/product/tca-quadrant-airbus-edition-de/

Bitte aktualisieren Sie jetzt auch die Firmware des Prodktes:

Falls Sie zu dem Updates Unklarheiten haben sollten, schauen Sie sich bitte folgende Aufnahme an:

Testen Sie jetzt bitte das Gerät im Windows Betriebssystem wie folgt:

  1. drücken Sie die “Windows” Taste + “R” Taste
  2. geben Sie “joy.cpl” ein und klicken Sie “OK”
  3. wenn das Gerät erkannt wird gehen Sie auf “Eigenschaften”
  4. testen Sie alle Funktionen des Gerätes.

Bitte zögern Sie nicht uns mitzuteilen, wenn diese Instruktionen Ihr Problem nicht gelöst haben.

Mit freundlichen Grüßen

Daniel, Ihr Ansprechpartner bei Thrustmaster.

Is anyone here who knows how I can rollback to previous update of MSFS 2020 because after latest one my Airbus TCA Officer Pack is going crazy (Sidestick also Throttle Quadrant Add-on is working only as they want to).
Thanks.

2 Likes

Currently, there is no way to rollback to previous update, it is a shared online platform for everyone. So everyone needs to be on the same version.

You can have a look at my setup and follow it. This setup works with every function on the FBW A32NX.





I made it from the current Default profile, then move around some of the bindings, removing the ones with issues while also setting new things differently. But overall, it’s still based on the current default profile.

4 Likes

Put your mouse in Legacy mode. I could use the mouse to start engine 1 and I got airborne without my previous issue of losing 80-100 kts of air speed and then never being able to recover. I climbed to FL29000 but now the issue was FL. ATC always saw me at a different FL than I was flying at. This sim has really turned into a joke. More game then sim, relying on graphics alone. ASOBROKEN

Yeah, ATC seems to not take the transition altitude into account. On my flight yesterday, I had to reset my altimeter to NOT use standard. So if the ATC told me that I’m 300 feet above my assigned altitude, I changed my altimeter to make it so that I’m 300 feet above the assigned altitude, and once there I pull the altitude knob to have it descend to the “current” assigned altitude and that usually silenced the ATC from bothering me anymore…

Until that is, you’re flying into another airspace with a different barometric pressure, the ATC will follow that instead and you need to reset your altimeter again.

I guess for now, I’ll just have to fly in Weather preset rather than Live.

I’m having the same issues, the fixes LS above helped to solve the engine problems, but still since the update the displays randomly shut down in all aircraft.

I’ve found that flicking the Eng 1 switch to off starts the displays up again (shows initializing) but then the engine shuts down.

It looks like something else is bound to that switch, but I can’t find what it is.

Anyone else have this problem, and resolved it?

Again, prior to this update, the quadrant + add on pack had been working fine.

Note: Have also tried the instructions provided by thrustmater for reinstalling the drivers and firmware, but problem still occurs.