[BUG LOGGED] TCA Quadrant & AddOn problem with SU5

indeed – applying “default” settings (for the Thrustmaster Airbus throttle device) doesn’t help

Here is the new settings page for mouse control.
Unfortunately here in German.

Same here! It is stuck on off after the update.
Also did anyone had random max flight level changes? It really annoys me and I can’t find a solution.

Seriously? This is pretty ■■■■ annoying.

1 Like

Have you tried this method that I found earlier?

1 Like

On the Zendesk site, it says you can try the Repair option or the RESET option, but if a full re-install doesn’t fix it as [DreadfulHydra50 has just done, then there is ABSOLUTELY no point in trying!

1 Like

There is no currant solution msfs somehow demapped engine 1 until they fix it or someone comes with a way to remap engine 1 then I don’t see any other possible solution.

1 Like

Sorry, that was a response to a specific post.

I have the same issue described. Engine 1 not working. And spoilers up and down crazy. Do we expect an update from fbw or from msfs? Thanks.


Yep, same here.
Also can’t see which joystick button I’m pushing… how are we supposed to map anything like that?
Hope there’ll be a fix, soon.

Also have the same issue. I also seem to have issues flying the A320 now too. It doesnt seem to set the speed properly and the ILS approaches seem broken is well. This is for both the A320 default and NX. Not great considering I spent the best part of nearly 5 hours just trying to download the update!

same issue with eng no1…also get CTDs after ‘click to fly’ in A32NX fbw. removed aircraft and have not had a CTD but the eng no1 and mapping/calibration issues persist…

The issue is solved by removing all bindings to the engine switches, except set engine 1 fuel valve and set engine 2 fuel valve for buttons 3 and 4 respectively.

1 Like

So, what you’re saying is to map only fuel valve and not the other two (don’t recall the other two things mapped to each of button 3 and 4)?

Not working for me. The switches starts to shake up and down and the engines doesnt start.

That solved the issue regarding the selection with the mouse! Thanks dflight8685! Now it seems I only have to wait for the Thrustmaster Airbus issue, that has no way workaround by now!

When i set it to joystick it isnt the throttle quadrant ?

Same here no engine 1 , what a mess !

1 Like

I resolved by doing the following:


Been playing around with some of the other aircraft and found some other issues that the button 3 problem has raised.

I tried some of the landing challenges that used twin jets or twin props and found the engines failed as soon as the flight launched if engine 1 was switched on.

I have gone through a couple of the profiles I created earlier for them and the CRJ and either unmapping any button 3 assignment or just leaving it switched off can work.

The profiles had also lost the gear mapping I set to the lower right button too (forget the number).

The profile assignments don’t seem to open up like they used to and the reset for the sensitivity curves doesn’t work too.

Definitely something odd has happened to the mapping. Still need to go through the other aircraft and the profiles I set up for them and do a bit more investigation.

Also on the subject of button 3, when you are flying ESC will pause the flight and take you onto the settings menus as before. However, unlike before, where you just pressed ESC again to go back to the flight you now need to use button 3 or the mouse to click on RETURN on the bottom menu.