[BUG LOGGED] VFR Flight Plan Bug (SU5)

Since installing SU5 yesterday, the World Map inserts two extra waypoints into my VFR flight plans completely messing them up…called “Time Climb” and “Time Approach”. They will show on the Nav Log in the world map and you can see the flight path getting skewed, however they don’t show in the flight plan in flight. The autopilot does still try to take you there so I have to manually choose to activate the next leg.

If I load the same plan in IFR, this doesn’t happen and the flight plan is as it should be in this screenshot.

VFR is completely messed up too.

Time to time only whenever, wherever, whatever.

Try IFR low altitude airways till its fixed. Almost working as long as you dont add/change POI.

1 Like

I have spent most of the day trying to figure out this TIME CLIMB and TIME APPROACH issue. Clicked on everything I could to see if I could delete them, looked for any settings where they were being auto added that I could disable. It has certainly killed the VFR flight plans and makes using the NAV autopilot a nightmare. If you fly to the TIME CLIMB point that seems to avoid the autopilot taking you back to your point of departure but, come on, with the price of this software, why am I having to come up with creative solutions to problems that were not there before. I have also had the same total nonsense where the TimeApproach sends you to a completely inappropriate place or gives a ridiculous flight plan that you cannot edit. I also noticed that while you can now add information on just about any way point you want (nearly down to the nearest toilet), it seems highly reluctant to show you the most vital things you want to know – i.e. your destination airport. On SU4 that was always visible from when you took off and when you got with 10 miles of the field the auto-assist ATC would give you landing permission and you would be shown the pattern entry. The airfield would be clearly marked too. SU5 has made this all a mess and needs fixing. I hardly every post on forums but wanted to get it in here in the hope that Microsoft & Co may realise they need to do something. Even allowing a roll-back option to SU4 for PC users would be an improvement and not hard to implement.

4 Likes

Have same problem with VFR flight plans, IFR works OK, tried VOR to VOR and GPS VFR flight plans with same result. Have to select DIRECT to follow flight plan. Need a fix for this, do not want to be forced to use IFR flight plans.

Was able to load VFR flight plan directly into GPS without the Time climb or time app.

If you experience this bug, please vote at the top of the thread. Thank you.

4 Likes

I am experiencing this bug and did vote. I have been searching on the forum for several days to find a fix for this. I like to create my flight plans on Little Navmap and load then into the sim. No problem before the SU5 update. Now all of my previously created flight plans get these Time Climb, Descent, etc. waypoints added and the plan is all screwed up. Please, please, get rid of these items or at least give us an option to turn them off. I was on a nice explore Europe tour, but have stopped for now because of this. Had about 100 short flight plans created, that are of little use now.

4 Likes

I’m wondering if this would work for you.

  1. Export the flight plan from LNM as IFR.
  2. In the World Map, choose your departure and destination airports, ensure all runways/approaches/departures are set to automatic.
  3. Load the exported IFR flight plan in the World Map (the waypoints should be accurate now. If it inserts an approach or STAR you don’t want, select automatic from the dropdowns again and reload the plan again)
  4. Once loaded into the flight, see if you can contact ATC and cancel the IFR flight plan. If you can, and the correct flight plan is still loaded into the plane, you may be able to proceed on course as VFR through ATC with the correct plan loaded without those nonsense waypoints.

I don’t use the in-sim ATC, I use P2A. So I’m able to load an IFR version of the plan into MSFS in order to get the plan loaded correctly in sim, and then I load the VFR version into P2A to get the correct routing as VFR.

An easy solution is to make sure you open your filters and set them to show navaids on the world map, set a direct path between airports, then hover of the VORs you want to use along the way, right click and add.

It’s also a good chance to plan your flight around visiting something interesting on the way.

1 Like

I’ve tried creating the plan from scratch in the World Map and still had the issue with those nonsense waypoints being inserted.

1 Like

Thanks for the suggested work arounds. I am an old B-52 navigator from the 60’s. The flight sim has been a fun way to get back into the old game of flight planning and flying. Little Navmap was a great way to make plans and fly them. This new thing just made it more difficult now. I won’t give up.

3 Likes

If you know how to navigate VORs you could always just set a starting point, jot down the VOR frequencies, take off and start twisting radio knobs and following needles. It’s always satisfying to get to your destination this way.

You could do it with a glass panel, but the old steam gauged birds just makes it better imo.

Edit: If you need a easy resource for navigation: https://skyvector.com/
Edit2: I just skimmed through this, but this seems to be a decent primer on using VORs MSFS: VOR Navigation Basics in the Cessna 152 - Microsoft Flight Simulator 2020 - YouTube

2 Likes

I’m not sure if this is a bug or not, but it definitely messes up all my carefully crafter flight plans. A simple way to remove these waypoints would be greatly appreciated, especially when importing a flight plan from Little Nav Map.

2 Likes

Check my post above and see if that’s a good workaround for you. I don’t use the in-sim ATC, so I’m not too sure.

Thanks for the workaround. I do already know how to navigate with VORs, but unfortunately I also use many waypoints since VORs are more sparse and many aren’t operational anymore IRL since the advent of GPS I assume.

Thanks for posting - I have the same issue. And I voted - so cheers.

1 Like

Same for me, only way now is do the flight plan in LittleNav Map and then manually insert the WPs directly into the GPS. Bummer!

1 Like

Voted.

This was a terrible idea implemented into the setup of a VFR flight, amplified even more by not being able to delete these waypoints.

2 Likes

Same issue here. Would like to vote, but apparently another bug is that I have zero votes to cast.

I have raised this as a Zendesk ticket about a week ago. I have voted here too. VFR flight planning is a mess. I now just spawn to my airport and parking spot. Then I use LittleNavMap to plot my course. The I program the GPS in the plane while I sit on the tarmac. I look forward to this being fixed, or being able to import flight plans directly into the Garmin GPS suite. :slight_smile:

2 Likes