[BUG LOGGED] XBOX Series X: Thrustmaster T.Flight HOTAS One - button assignment works incorrectly

Precisely this is what happened to me… I was trying to hit F2 and it comes up as B4 for me.
I tried a few others and the same thing happened The button pushed does not translate to what the game shows and you end up having to sort of hunt and peck to find what is what…

Someone mentioned using the back ports instead of the front ports. Has anyone confirmed or had any luck using this method?

Also using the default mapping as they suggest doesn’t work either.

1 Like

Same thing happening to me, thought i was going mad at first but soon realised its not just me, hope they fix it soon!

I had issues. Plugged it into back of Xbox and flight stick works. Thank you for advice. Not all buttons work but you can fly and use controller for the button pressing. Hopefully an update will come soon. Can you update your controller on a MacBook ??

Yep I’ve got the same problem….
I really hope it’s sorted out soon :crossed_fingers::crossed_fingers:
I was all psyched to get seriously into the game, but trying to do all the training with messed up inputs is a pain in the a**
So now all I’m doing is goofing off in game. :disappointed_relieved:

What’s your gamer tag ? Mines SEVEN7SEV3N….

I’m guessing our user name is our gamer tag….lol

1 Like

I too was so disappointed as I wanted to do some long haul flights which I could not do with my pc as it uses an egpu which has the issue of loosening FPS over time even though cpu, memory, vmemory, disk io is all fine as well as the temprature for everything.
So instead now, I am just learning how to fly using the Xbox controller, which is growing on me by the way.
The only real other concern that I have with the game are the block boxes on the screen which are cause by both the map and comms windows. Which I have figured out to be because they setup on the pc as external popped out windows on my second monitor. That is why when they open on the Xbox are not partially transparent. The work around for this is to close the windows and then select to restart the flight, then most of the time they open within as normal.

This does work to a degree. I saved a copy of the default map to start with and then worked through the functions/buttons by clearing the inputs then scanning for the new input and validating each one. Although you cannot use all the buttons anyway as several of them scan as the same inputs giving you various conflicts anyway!
It was interesting using the scanning function to see what input was actually recorded for a particular labelled button - only 2 or 3 i think were correct!
We desperately need Thrustmaster and FlightSim to resolve this asap.

1 Like

Same issue here, buttons report correctly on PC, but they’re all mixed up on XBSX.


1 Like

I used mine for the first time today and the native FS mapping worked fine. I have not tried to do any custom mapping. Hope to try to customize soon. Good luck to everyone.

Same issue here. Using a controller for anything except flight control, but it’s def not ideal. Need the button mappings fixed please :slight_smile:

That would be fine except some of the buttons aren’t listed when you want to make an assignment. Very frustrating

1 Like

Same issues here… it doesn’t feel like they did any testing what so ever with the Hotas One before releasing it… I would have thought it pretty embarrassing if I was Microsoft that their licensed flight stick behaves like this…

We’re only at 4 votes. Everyone needs to vote for this issue.

Edit: You earn votes by reading posts while logged in: Trust Levels and How To Advance

You must:

  • Enter 5 topics
  • Read 5 posts
  • Spend at least 15 minutes reading posts

Edit 2: fixed link


@RUFIOKing How can I vote this up. The vote button is labelled “LIMIT” for me, if I try to vote it says I’ve reached my limit of two votes. I have never voted for anything, my profile shows no votes either. Works as well as the flight stick config…

1 Like

@Doomsday4719 I just figured this out. You earn votes by reading posts while logged in. You must:

  • Enter 5 topics
  • Read 5 posts
  • Spend at least 15 minutes reading posts

Edit: fixed link


@RUFIOKing THANK YOU! I’ll read for 15 mins then and then vote this up.

(Edit: Worked!)


My problem is that as soon as I click the input field, “F2” immediately assigns itself, overriding any other button presses that I make on the stick. My Hotas has been plugged into the rear of my XB1X, since day 1.

If I go into another game and try programming the Hotas assignments, everything works correctly. So, it appears to be an issue in MSFS specifically.