[BUG] WMR start menu overlay crashes VR mode

, ,

There is a bug that causes VR-mode to deactivate when pressing the windows button in VR (while WMR commands are active (win+y key)) in cockpit.
The start menu WMR overlay works while being in the MSFS menu and only crashes MSFS VR mode while being activated in cockpit. It was working before (before public release) and as both programs are from Microsoft, the functionality to open windows and apps inside the cockpit should be supported in order to do serious simming.

No screenshot needed it will just crash MSFS VR (return to MSFS 2D and go back to cliff house environment.

Steps to reproduce the issue encountered:

  1. Activate VR mode inside the cockpit.
  2. Change input to WMR (Win + Y key)
  3. Open WMR start menu overlay (Win key)

Thank you for this! I thought I was going crazy crashing VR while trying to open the WMR start menu in the cockpit. I hope this gets fixed!


I reproduced it too. Can confirm it. Is there any (other) way to get an app or window from desktop into VR (WMR)?

Great to see this finally getting some traction - hopefully the WMR/MSFS team will investigate this.

I mentioned it somewhere else: For now, you can open windows in the cliffhouse environment or in the MSFS main menu and make them “follow” you. This way virtual windows will remain in your view when you load into the cockpit. Once you are in the cockpit, you can move to a position that suits you and control using win+y. Just try to avoid hitting the windows button by accident.

Can we interact with our mouse with the virtual screens in VR?
I tried but It always frustrates me because of these crashes and in VR I find it hard to locate the WIN+Y keys.

I just want a tablet as desktop screen in VR that I can use any program and browser window like on a regular desktop.

Flying VFR requires a lot of charts, Sectionals, AIP, VPilot, Notepad, etc, etc.

After hearing from another user that he doesn’t have this issue (thx @NguyenQHy) , I have been playing around with every setting to reliably prevent the crash in cockpit. I will give updates once I find better solutions but for now:

  1. Setting motion reprojection in OpenXR to AUTOMATIC
  2. Hitting Esc key before initial WMR start (doesn’t seem to be necessary after initial run)

Hopefully together we can get closer to the root-cause and help Microsoft/Asobo fix this as I still believe this is a great feature of WMR headsets. Perhaps @Jummivana can forward this thread (as she has done with previous workarounds) :slight_smile:

1 Like

I’m still having the same problem. after googling around I found this: https://www.reddit.com/r/WindowsMR/comments/k3kiz9/windows_button_on_keyboard_and_sometimes/

I reported feedback, lets see what happens now coming from the MS WMR team.

And Betze7210, what do you mean with step 2?

I sent them this bug months ago - even uploaded all of the supplementary files but there has been no acknoledgment since then. Anyway, it can’t hurt to try to get their attention through multiple channels.

To clarify: Before I use the WMR start menu overlay inside the cockpit for the first time, I hit the Esc key in order to go into the menu and pause the game.
After I have opened the WMR start menu once this way, I can reopen the WMR start menu freely without pausing the game.

I mentioned in another topic that this seems to be resource related where the initial WMR start menu launch will crash VR mode if there is not enough resources. I believe hitting Esc key helps with that and once it ran for the first time it’s not crashing for me anymore.

Let me know if this is still unclear.

1 Like

This makes sense, thank you for elaborating!
Will definitely try this when I have the chance!

No problem - let me know how it goes.

No changes for me regarding this Bug with the latest sim update.

Setting the motion reprojection in OpenXR dev tools to automatic is the only way to prevent VR crashes.

1 Like

Tested latest WMR driver updates: 10.0.19041.2041

Still getting crashes when reprojection disabled. Even with it being on automatic I crashed VR mode this time.
Sadly this issue does not seem a priority given that it has more votes than a number of bugs on the Dev roadmap. Very unfortunate that this non-functionality of WMR is left untouched.
Only option remain: WMR start in MSFS main menu or use cliff house environment to set everything up (make windows follow) and deactivate VR mode after…

1 Like

Having the same problem running Reverb G2 in FS2020 with WMR. It works till I start the flight. I can go through the sim’s menus. When I enter the flight in the cockpit or works till I start the flight. I can go through the sim’s menus. When I enter the flight in the cockpit or external view, Mixed Reality kicks me out to the Mixed Reality Portal.

1 Like

I’ve noticed the issue as well, because of it I can no longer record videos in VR.

I used to be able to press the home button on my Reverb G2 controller, which would bring up in MSFS a WMR menu that has actions at the bottom to take a screenshot or record a 5 min video. Now instead MSFS exits VR whenever I press the home button.

Thanks all for voting and sharing your experiences. Being able to flawlesly open and interact with the WMR would enable many useful features (3rd party apps/charts/recording in VR). Given that MSFS is looking into controller support, the exposure of this bug will certainly increase (as a VR crash will be only one click away).

Great to see that the bug is finally recognised and “under investigation” in the roadmap:

If any dev is looking into this and needs further explanation - feel free to reach out. I also reported this via zendesk with all diag reports etc.

I have recently updated to the latest driver as well as the Windows Insider Preview in order to get the nex WMR update.

So far after very limited testing, I can reiterate my previous finding. The motion reprojection seems to be key in this bug. With automatic enabled, it doesn’t seem to crash. Hopefully the fact that this is linked to motion reprojection should allow the devs to locate the root of the bug.

I have had the same issue. Today, for the first time, when i press the windows button (accidentally) the windows VR menu pops up in the Sim, rather than crashing back to the cliffhouse. Anyone else noticed the same? Will try to reproduct this, i was flying like this and it was amazing, i could re-open my browser even when it had accidentally disappeared. LIke this i can fly procedures. Amazing if that works now.

Thanks for sharing your experience. I will test this myself later today.

It has been working since the last OpenXR update when activating motion reprojection.
Could you check inside the OpenXR dev tool whether this was the case for you?

And yes, it really adds to the experience when it’s working :slight_smile:

I have set motion reprojection to automatic, so i guess this is the reason then. Anyhow as long as it is working it is pretty much amazing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.