Bush trip Balkan leg 12 bug

This is fixed now as of the update that was released yesterday! You can land or taxi on the runway now and come to a complete stop and it should complete.

1 Like

Don’t be so happy, next leg with landing on LGSO have simmilar issue. Airport is visible on map but after landing nothing happend. It soo dificult to finish bush trip. :frowning:

OMG it’s true, next leg is landing on LGAK and it’s also broken! These guys at Asobo/Microsoft don’t do any UAT apparently.


Yup. So dang frustrating. I’ve been waiting on them to fix 12 and now I have to wait on 13. Ridiculous


Nope - all is well in bush trip land.

Now, it appears if you ever quit to menu and reload any bush trip, you can’t land at the next airfield (haven’t tested all of them).

Some still lose all POI and the VFR flight path, some don’t - you know, typical MSFS 2020.

I submitted a ticket for 13, just like I did for leg 12. Absolutely stupid, at this rate I won’t finish this bush trip this year.

1 Like

can you guys check whether the regarding Airfields are visible as “Airport” in the Worldmap?

I also just discovered that literally the “next” airport is broken as well. The Iceland bush trip can’t be completed either. I wonder which bush trip to start now :wink:

Don’t they BETA TEST the Bush Trips? Surely they have someone at a computer who can fly these to make sure they aren’t broken. I can understand they can’t check every airport but these are intrical to a main feature to the sim.

Better to vote a single thread up:
SU5/SU6 and Bush Trips - Bugs & Issues / Online Services & Activities - Microsoft Flight Simulator Forums

And the more specific tickets in the better.

Correct me if I’m wrong but it’s still broken after the GOTY update right? At least mine is still not registering.

1 Like

Yes, still have this same issue.

1 Like

I tried restarting the bush trip from the previous working leg and then moved on and this time it registered fine.

1 Like

I had to do the same. Starting from where I left off always resulted in an empty navlog. So I went back one leg and re-flew that as well.

You are right guys! Thank you, I finally finished bush trip. As you said, I have to return to leg 11, start it again and it works. Yeah! :slight_smile:

1 Like

This issue existed before SU5, I don’t know if that airport has actually ever existed properly in the game and only exists for the Bush Trip

However, I managed to complete that leg and the whole Bush Trip by basically landing repeatedly on anything and everything that remotely looks like it could be landable in that area. Eventually the stage completed.

At present there are a whole bunch of other issues that have appeared with Bush Trips so I’m not sure my tip is at all helpful anymore.

Hi Everyone:

I’m sharing my experience with an empty NavLog during Bush Trips-- specifically with SU7.

I made a mistake during one of the legs and crash landed. After crashing, I was presented with a number of options I think they were: ‘Continue’, ‘Restart’, and ‘Main Menu’. I hit the ‘Continue’ button (I think I should have hit ‘Restart’), which resulted in the plane immediately crashing-- it put me in the water! Anyway, it then automatically reloaded the leg from the beginning and the NavLog was now empty. (Note: the VFR map did show the leg’s POIs and white guiding line even though the NavLog was empty).

The GOOD NEWS was that I didn’t need to “redo” the previous leg in order to fix the empty NavLog (per the recommendations on this thread). I simply completed the leg with the empty NavLog, and upon a successful landing the NavLog re-populated with the next legs waypoints, etc. All was well!


Hmmm, now I am waiting for weeks to have this bushtrip working. what if I don´t know how to fly without ? Are they serious ? how long do they need to fix the bugs ?

It’s the usual. I had to re-fly the previous leg. Then I was able to continue without issues.

What happens when the first leg is broken?

I was too hard on the brakes during landing, lost control and crashed. I was then presented with the “continue” “restart” and “main menu” options… I made the mistake of hitting “continue.”

Word to wise: NEVER select “CONTINUE” after a crash during Bush Trips. It just seems to break things.

So, what happens now… It spawns me a mile or so from the destination airport and even upon landing properly it doesn’t register. Nothing. Yes, I’ve triple checked that the airport I’m landing at is the correct one. Moreover, even if I click “restart” button it still spawns me at the location mentioned above. It does not put me back at the departing airport. In other words, it doesn’t actually restart the leg, just puts me back at the “continue” spot a mile or so away from the destination airport.

I would like to delete the whole save file and start over – BUT – I’m on XBOX.

Any ideas?