Bush trip landing detection still broken?

I started the Nevada Bush trip back when the sim first came out. Got almost to the end and then the patch got released and broke the detection. Apparently this bug has been fixed but it’s still not detecting the landing for me when continuing the previous trip. I’m sure I landed at the right place. Are other people also experiencing the same issue?

1 Like

Same here. After 2nd or 3rd update, I finally resumed the Nevada trip but found I had to start all over before my landings where detected. I’ve completed the Alaska and Balkans bush trips since and haven’t had any issue, but that was before this latest update.

That’s a bummer I really don’t want to start the trip from scratch as I was near the end and have just been waiting for the bug to be fixed. Kind of hoping somebody has found a workaround.

If somebody has a save starting at leg 17 of Nevada Bush trip, that’d be much appreciated.

Go back and re-fly the previous leg (probably leg 16 in your case) that shows you completed. You MUST re-fly that leg, whether you know you completed it or not. Once you’ve done that everything else should fall back into place.

It busted my chops for months before I came across “the fix.” It sucks for sure.

What I did was re-fly all the bush trips when I got my Quest 2. It was a whole new experience. Very cool VFR in FS 2020. I also spent more time sight-seeing the second time around. :slight_smile:

It’s not a bug. It’s a “feature.” :wink:


Good shout, thanks for the tip. Sadly it didn’t work for me to refly the last completed leg. I am thinking of just flying the whole thing again… You’re right about the VR, I started flying with my Index recently and it’s just a completely different experience.

The same here. I completed the first leg of Nevada two times and was not credited with completion. I can’t understand how such issues can still be a thing so many months after release, especially that It worked fine right after launch…I will puke if I have to fly the first leg of Nevada again.

1 Like

I know how you feel, I really didn’t want to fly from scratch. The bug is marked as “solved” and topic closed in the voting page which is particularly frustrating. I asked the mods to reopen it but didn’t receive a reply. But first time I flew with 2D screen, now I’m reflying from beginning in VR so it’s still interesting.

Any chance either of you are using (or used) the “dev mode” while flying those Bush trips?

“But first time I flew with 2D screen, now I’m reflying from beginning in VR so it’s still interesting.”

And for me it’s taking far longer to do them. I’m doing 10 times the “looking around” that I did in 2D mode. When you fly down a valley or between some trees at a dirt strip… it LOOKS REAL. Pretty amazing. I only wish I didn’t need a multi-thousand dollar video card to make it smooth with all the eye-candy turned up to high. I have an AMD RX590, which does just fine in 2D mode.

1 Like

I did use it to create/adjust some scenery but I don’t imagine that could have an impact? I didn’t use it during bush flights.

It was more of a “just in case” question. :slight_smile: But if it’s not working (even with Dev Mode off) it’s obvious something else is causing you grief.

I finished Nevada bush trip months ago so my tricks here may not solve your problem since it’s been too many updates. It worked the time I played.

MFS bush trip leg trigger seems to be a geo coordinate with a certain offset allowance. So you may try taxi your plane slowly back and forth along the target runway to meet this trigger spot.

Sometimes it won’t trigger just simply because you land on a wrong adjacent airfield.

1 Like

Interesting. That did happen to me on one of the other runways. I’ve started this one from scratch so if the issue repeats when I get back to where I left off, I guess I’ll know I wasn’t at the right spot on the runway.

I’ve read bush trip package files, so believe me, these trigger spots really exists. :innocent:

1 Like

Update: After restarting the whole trip by deleting the save files and flying back to the same place where landing wasn’t recognised, it’s now recognising the landing just fine. So it looks very much like a bug where if you have an old save file things don’t seem to work.


where do you delete the save files for a trip

Not sure if it’s in the same place for every version of the game, I’ve got the Steam version. But for me it’s in this location: %USERPROFILE%\AppData\Roaming\Microsoft Flight Simulator\MISSIONS\ACTIVITIES

1 Like

I’m always getting “leg completed” after landing so everything looks fine initially, but when I exit to the menu, my progress is not saved. It happens in Nevada and Rijeka to Santorini. I even tried to fly two legs of Balkans in a row, to no avail. Anyone having the same issue ?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.