Bush Trip Nevada doesn't work anymore after update

I started the bush trip in my Savage Cup and reached Ravendale (Leg 15). Now (after the update) I wanted to continue, landed at the airport Spaulding (Leg 16) but FS didn’t recognize my landing. I tried this leg several times and stopped at every possible point on the runway and on the parking but no success for this leg. And yes, it was the right airport, I checked it viewing this leg on youtube. Then I tried the previous leg and now Ravendale isn’t recognized anymore, too.
My legs-plan now looks kind of silly too: There is the little plane at leg 15 where I have to continue the trip, but I have a checkmark at leg 16, a leg which I haven’t officially ended. What can I do?

Hi SengirVamp,

I’m a couple of hops ahead of you on that bush trip, and I was able to land and complete the leg successfully just now. So while it sounds like a bug, I don’t know that we can say it was introduced generally by the patch.

I can confirm that the Spaulding leg should finish on the runway as usual; there were no special requirements, for example to go to the parking.

So this post isn’t a lot of help, except to provide a little info, sorry.

Same issue here. It looks like something breaks when the version of the game is updated for some reason it doesn’t recognise when you land. You can vote to fix this bug here: No bush trip landing detection after patch2?

Hi every body !

Another issue in “Bush Trip Nevada”: no more information about the trip to fly (n°10) !
No waypoint information, which airfield do I have to land ???!


You need to refly the last full leg to get the directions back. But I’d do it only after the landing recognition of fixed.

Thanks a lot MetalSalmon3852.
I gonna test this.