Bush trip - not saving progress

Confirmed bush trip is now saving for me. Phew.

1 Like

Oh, that’s excellent news! I was bracing for no change

I hate to blow the candles out here, but I CAN report Bush Trips not recording progress I’m afraid.

GOTY update applied without issue. No mods or anything at all in Community Folder. DEV mode off.
Flew the AUSTRIA TYROL HIGH MOUNTAINS and got the completed leg verification but still didn’t register.

I can also confirm that bush trip legs are completing but not recording progress as completed.
No check mark showing by the last leg completed in the bush trip menu.
Flight ended and log showed 00.00 showing in hours flown.
Aircraft icon moves to next leg of trip.
Also, of note, only four characters show in the waypoint display still.
No flight plan route line showing on the cockpit MFD when using GPS.

Since SU5 dropped, these issues are persistent and need to be fixed.

As a bush trip developer, right now, it’s pointless to try and create new trips because of the broken system for activities in MSFS. Bush Trips, Discovery flights, flight tutorials, etc. all seem to have lost the ability to save progress and give credit for those activities.

2 Likes

Ok, I was really looking forward to going back to bushtrips but they are still bugged…

I just tried 2 different bush trips (one official, the alpine grand challenge, and one community made, the Norway fjords part 1) and neither legs recorded as completed when I was done.

2 Likes

So, it’s 1st of February 2022 and Bushtrips are still broken. I just checked with Santorini trip and legs are completing but not recording progress as completed. Flight ends, completion mark shows up but that’s it. flight is not progressing. I tried to go straight to the next leg and then exit to the main menu but it doesn’t help either. They are shown as 00.00 in Flight Log. I’ve alreay voted in SU5/SU6/SU7 and Bush Trips.

And yet, they still keep adding new ones

image

1 Like

Still not Work… Shame on you MS and Asobo… So many Hours for Nothing. Thanks for NOTHING.
ALL THREE BUSHTRIPS I MADE SHOWS 0 % …

Zero Stars on MS Stor for THIS

1 Like

Yep! I just made the 2 legs of the new Australian bush trip Sea to desert: it registered the first 2 legs so I could continue but the second leg has never ended on the “completed” announcement. So when I restart, I’m always at the end of the second leg.

1 Like

I created a new user account without accent (for my case é) and now the leg save are working …

Here’s what might work.

a) Turn off AV or apply exclusions to everything MSFS.
b) Run MSFS as admin
c) enable dev mode
d) Start bush trip
e) close VFR map
f) Start timer in Nav log
f) In dev menu Windows section pull up Teleport window and teleport yourself to the next airport.
g) You’ll get leg completed splash
h)Click Next You’ll get the summary screen
i) Click Continue You’ll get nav log and VFR popups back.
j) exit back to main menu
k) go back into the bush trip select last leg and hit restart from, then rinse and repeat with teleport.
l) Make sure all your MSFS folders are set to read/write for everyone group in windows instead of just admin.
It seems to force generate save files that way and get you that achievement and after that you can actually fly it :).

1 Like

This worked for me! Thank you :grinning: :hugs: :raising_hand_man:

Not only are the legs not being recognized as complete, but in the Alaska trip the engine would slowly throttle down like it was too hot for too long or out of fuel causing a forced landing. This would happen at different points on the same leg and on different legs. Still haven’t finished the Alaska trip.

Does step “d) Start bush trip” mean I have to start over from the beginning/first leg of the bush trip and do it all the way through from leg #1? Or can I start from the one leg I have in the middle of the trip that isn’t finished? For that one leg I have, it hasn’t detected I was finished automatically after stopping on the runway, so maybe it’s a different issue, not sure… this is the Patagonia trip, btw.

I am still having part of this problem, on the final leg of the Discover Iceland bush trip. This only occurred on the last leg (leg 8, from Patreksfjordur to Reykjavik). The other legs worked fine and completion of each one resulted in sensible % progress numbers on the Bush Trips menu.

I completed the flight of that last leg 8, came to a stop on the runway of BIRK, and I got the completion screen:

In the list of legs for this bush trip, it shows the checkmark (indicating the leg has been completed) on the list of all eight legs. So far, so good:

But when I check on the Bush Trip menu, it is showing Discover Iceland as 87% completed, whereas it should now be showing 100% complete.

I flew that entire last leg 8 again. Same result: showing 87% Completed when it should show 100% Completed.
Very annoying!
Asobo and Microsoft, please fix this!

Once you’d completed the trip did you exit the sim and re-start before going back to the bush trip menu? If not you won’t have necessarily picked up the latest status for the trip. When I finish the final leg of a trip I normally choose the return to main menu option, then exit the sim. On re-starting the sim will pick up the actual state of each trip as stored in the saved missions (on your disk somewhere).

Bushtrip now saves the progress if you press the continue button after completing a leg. But this is still an issue as when I finish the last leg I can’t press a continue button so the bushtrip never completes %100. It thinks the trip is not finished and shows %9x progress.

I just tried the Sardinia Bush Trip in the latest update which is quite easy as all you have to do is fly the course in the heading display. I finished leg one by landing at an airport and because I needed a break decided not to continue at this stage and exited back to the desktop. When I started it again about an hour or so later at the airport where I landed the course had disappeared from the heading display and also from the mini-map.

With the exception of the final leg of any bush trip ALWAYS continue to the next leg once you’ve finished a leg. Once the next leg has come up on screen it’s safe to exit if you don’t want to carry on. As far as the vfr map is concerned why use it at all? It’s of very little use. If you really want to see your position on a map use little navmap.

Yes, I now turn the mini VFR map off now as you have said it is of little use.