Bush trip - not saving progress

It’s a strange bug.
I have some that show correct info but still won’t complete.

go figger

Not working for me either. In-fact, the navlog doesn’t event propagate upon starting the bush trip. It’s blank. 0% completion. I even got the checkpoint screen yet no %. Annoying!

Same here, did 2 landings, both shown popup with resume of flight, exit to main menu, progress 0%, I have to start from the beginning.
PC 1.20.6.0

now im getting this on patagonia, ■■■

1 Like

Finland trip, even with the leg description correct, it won’t detect your landing, if you teleport with dev mode it registers the leg completion and saves it. Patagonia and France trips are the other ones I tried, both with leg description incorrect and not saving.

1 Like

Same bush trip problems for me on xbox, it has become worse in that now leg completion is not recognised, nav map lines not visible and way point guidance just points at 000 all the time.
I really enjoy this part of the sim and it’s a shame the number of bugs are making it unplayable!

2 Likes

I’ve been having this issue on an off since release. I can’t register my last leg and so I am quitting bush trips for now until Asobo addresses this directly.

1 Like

The same here. Bush trips are not saving progress.

1 Like

upvote this thread same topic - [SU5/SU6 and Bush Trips

1 Like

This thread was created a while ago when the bush trips saving problem had some workarounds. Before, I could delete the mission folder to restart from scratch and progress saving would work again. But now, looks like recent updates really messed up bush trips saving progress for good. I even tried to completely uninstall and reinstall MSFS, still not a single leg would save anymore. Really hoping that this known issue gets its due attention. https://flightsimulator.zendesk.com/hc/en-us/articles/360016027399-KNOWN-ISSUES

Hi all, same here. Tried both Balkan and Patagonia Bush Trips. In Balkan trip, I had completed already 10 legs. Now I have to start at leg 1 over and over again. Same for Patagonia. And as many people here, I can see the files saved in the \MISSIONS\ACTIVITIES directory.
I hope they can really solve the bug, the bush trips with VR are awesome!
Already voted

First when the update came out I seemed to have lost all my activities progress for ever.

So yesterday I decided to restart all over again starting with the French bushtrip. Today I’ve opened up msfs and I’ve discovered a similar issue which seems like a loss in progress with a similar bugged screen with the strings being iterated as raw. There is one more detail to add onto it.
After following the steps and tips from early in this forum post Ive obtained the savefiles of the bush trip.
source1

It seems like the game struggles to read the saves and the entire system seems inoperant. I highly doubt that we (the users) can find a solution to this problem. Hereby my only hope goes to the msfs team to give them more feedback, awareness and information about the issue. Hopefully this will be helpful information for finding a solution to this problem. And Ill be looking forward for a hotfix within the next updates if possible.

For now I think that all we can do is wait for the devs to solve the problem.

extra info: my copy of msfs is a microsoft store pc copy, currently running on v1.20.6.0 with developper mode switched off.


the second source for the post above (the forum denied posting both sources at once unfortunately)

SU7 released today. Still downloading will try bush trips soon. At least the bush trip failing was removed from known issues list. Anyone else got it fixed now?

Confirmed bush trip is now saving for me. Phew.

1 Like

Oh, that’s excellent news! I was bracing for no change

I hate to blow the candles out here, but I CAN report Bush Trips not recording progress I’m afraid.

GOTY update applied without issue. No mods or anything at all in Community Folder. DEV mode off.
Flew the AUSTRIA TYROL HIGH MOUNTAINS and got the completed leg verification but still didn’t register.

I can also confirm that bush trip legs are completing but not recording progress as completed.
No check mark showing by the last leg completed in the bush trip menu.
Flight ended and log showed 00.00 showing in hours flown.
Aircraft icon moves to next leg of trip.
Also, of note, only four characters show in the waypoint display still.
No flight plan route line showing on the cockpit MFD when using GPS.

Since SU5 dropped, these issues are persistent and need to be fixed.

As a bush trip developer, right now, it’s pointless to try and create new trips because of the broken system for activities in MSFS. Bush Trips, Discovery flights, flight tutorials, etc. all seem to have lost the ability to save progress and give credit for those activities.

2 Likes

Ok, I was really looking forward to going back to bushtrips but they are still bugged…

I just tried 2 different bush trips (one official, the alpine grand challenge, and one community made, the Norway fjords part 1) and neither legs recorded as completed when I was done.

2 Likes

So, it’s 1st of February 2022 and Bushtrips are still broken. I just checked with Santorini trip and legs are completing but not recording progress as completed. Flight ends, completion mark shows up but that’s it. flight is not progressing. I tried to go straight to the next leg and then exit to the main menu but it doesn’t help either. They are shown as 00.00 in Flight Log. I’ve alreay voted in SU5/SU6/SU7 and Bush Trips.