Bush Trip POIs disappeared after first leg

Hello! For those experiencing this issue, we’d love your help with some specific information:

  1. What are the exact steps you are taking to see this issue happen?
  2. Which Bush Trip has this happened to you on, and are there any where it doesn’t happen?
  3. Is it always the first leg, or does it happen for you on other legs too?
  4. Are you on Xbox or PC?

Hi guys. I hope Asobo also know that the Nevada Bush Trip won’t save the progress anymore.

  1. An otherwise normal bush trip suddenly ends when the landing at a leg’s airport does not register as complete. No further legs can begin after that point.
  2. When mine failed in Germany and I read posts of other players reporting the bug in so many other trips, I stopped doing bush flights.
  3. Germany 6th leg for me ended my trip yet I have read that other players’ trips ended on earlier and some later legs.
  4. PC
1 Like

Hi Jayne,
This has happened to me on the Patagonia Bush Trip

  1. The first leg works fine, in fact the POI’s and navigation line in the VFR map shows for multiple legs if you complete them consecutively without exiting to the menu
  2. Patagonia (is the only one I’ve tried since WU6)
  3. First leg works, subsequent legs work if I dont return to main menu. Once I return to the main menu, continuing the bush trip removes all POI’s/navigation line. I have found that if I restart from the first leg and complete it, and then go back to the leg I was upto previously, the POI’s and navigation line does show up again until you go back to the menu.
  4. PC
1 Like

Hi Jayne, hope this helps:

  1. Trying to continue a previously incomplete bush trip - my Germany bush trip is currently in the state with no POIs / GPS coordinates showing on leg 2 (happy to share any files to help debug).
  2. Occurred on all the ones I was able to test (Germany, Norway, Sweden, etc.) prior to losing progress. Have tried recreating the issue but even leg 1 no longer registers as complete (even though the dialog appears when completing it).
  3. Occurred on subsequent legs as well.
  4. PC
1 Like

Yes - this thread was marked as bug-logged. Fingers crossed…
Bush trip - not saving progress - Bugs & Issues / Online Services & Activities - Microsoft Flight Simulator Forums

1 Like

SU6 introduced “Completed Leg fails to save”, I can’t test the Bush Trip VFR map as it’s impossible load previous Bush Trips without losing progress or start afresh past the 1st leg.

  1. Load a Bush Trip - Standard, DLC or User Created, Play in SP or Group with a friend to fly co-op.

  2. Balkans (SP), Norway(co-op), Denmark(co-op) and user made “UK Coastal Bush Trip Part 5” in both SP and MP (co-op).

I haven’t found a Bush Trip that worked reliably, though I did complete leg 1 of “UK Coastal Bush Trip Part 5” in co-op. However the other player could not trigger the “leg complete” message and leg 2 fails to complete for me.

  1. First leg in a “clean” Balkan’s save displayed “Leg Complete” but failed to progress.
    Have had it fail re-flying legs in previously completed Bush Trips, some times doing so removed the “check mark” from previously completed legs.

  2. PC (Steam)


I’ve had this on most Bush trips. Definitly on Finland, Danmark, Sweden, Germany and Island. The Alaska Bushtrip only registered the first 2 legs but then I could continue the next leg without the symbol and the percentage stayed at 8% completed.
It might only be the first trip that works when you start them from scrach. Not sure if you started a trip before SM5.
i am on PC steam edition.


Reproduction is pretty easy:

  1. Start the Switzerland Lakes Bush trip
  2. Land at the Airport at the end of first leg, Leg complete screen comes up
  3. Go to Bush Trip Menu then to Start Menu
  4. Try to continue the Switzerland Lakes Bush trip …

You will again and again and again start at the first Airport at the first leg


I also think they are trying to reproduce the issue with losing the POIs / gps route on subsequent legs.

The issue introduced with SU6 not logging progress makes it more difficult to reproduce because you can’t even get to the next leg (which is why you may need to find an incomplete one that was started pre-SU6).

This was my chronology with the bush trip issues:
Release to SU4: no issues → SU5: lost progress of ones completed (reset from 100% to 0%); introduction of POI / GPS loss in subsequent legs; inconsistent triggers for leg completion → SU6: progress on legs not being saved

1 Like

Hi Jayne,
I’m very pleased to see someone from the FS team coming forward to take this on - it’s about time. Thank you very much for your interest.
In principle, I can only repeat what has been said here before.

  1. the problem always occurs when you return to the main menu after finishing any leg.
  2. all bush trips are affected
  3. see point 1.
  4. PC

After almost every update, something in the bush trips broke. That is the main reason why only a few users are interested in playing them anymore. You can see it in the participation when voting is done. All the problems are named and described in this forum. That’s why I’m glad you want to take care of it now and hope your interest will last and the other problems can be fixed too. Glad that you are here.


Here is the answer to the questions

  1. As said, this is quite systematicaly reproduced in any leg if you quit the bush trip activity - going to main menu or leaving MSFS - and going back later to the bush trip
  2. It affects all bush trips I tried since SU5 , I tried at least Iceland, Finland, Alps, Swiss lakes
  3. It affects any leg.
  4. PC, in VR or not

I can also tell that the mission save directory sometimes gets corrupted ( e.g. … localState/MISSIONS/ACTIVITIES/ASOBO_BUSHTRIP_XXXX_SAVE/ASOBO_BUSHTRIP_XXXX_SAVE) and it seems related. I donb’t know if this can help

It seems that the content of the directory differ if you look at it just after a leg is validated (A), or if you have gone out of bush trip back to the main menu (B). in (A) the main FLT file containes the start and end point and POI for the next leg. in (B) no POI no more, start time, start and end point are reset to the ones of leg one. => this file and perhaps other gets reset when exiting the bush trip to go back to the main menu.

NB : I had a first look at this directory only a few days ago, due to another problem
In leg 1 I crashed the plane before even taking off ( That’s why I fly only in sim :slight_smile: )
when restarting the leg, there were strange display bugs. the display of the VFR map was impossible and the panel with the POI description would not scroll nor resize, and the chronometer was in the middle of the panel. I tried restarting the flight / quitting MSFS , to no avail
The instruments where giving the correct directions nevertheless, so I managed to do the flight, but when landing in the arrival airport it would not validate the leg.

The only thing I could do to be able to restart the bush trip from start was to delete completely the MISSIONS/ACTIVITIES/ASOBO_BUSHTRIP_XXXX_SAVE for this bush trip. it accepted to restart fresh. I could validate leg 1, and leg2. did a copy of the dirs at this point… then I stopped the sim and of course had a problem when restarting leg 3. NB: resetting the dir in state (A) brings back POI, but will not allow to validate the leg.



this is what I’m experiencing (I’m on PC):

Steps to repro (I’ll list exactly what I did, as I did it. It’s probably not the shortest path to repro the issue):

  1. Start the Grand Alpine Challenge bush trip
  2. Complete the first leg => MSFS detects the end of the leg as expected (when landing at LSGB) and shows the appropriate dialog.
  3. Click on the button that will take you to the main menu (not the bush trip menu)
  4. Exit the sim when you are at the main menu.
  5. Start the sim.
  6. Select the Grand Alpine Challenge bush trip again (MSFS remembers that the 1st leg is completed, the “tick” is shown as expected next to the 1st leg).
  7. The aircraft spawns at LSGB (where I landed, as expected)
  8. First weird thing, at the top of the glass-cockpit the “WPT” / “DIST” / “ETE” fields are empty. That was not the case when I started the bush trip from the begging: I was able to see the data for the next POI (POI1 / POI2 / etc…)
  9. See that there are no POIs/ no track on the VFR Map
  10. After flying this leg (with the help of NAVLOG text only), the end of the leg is not detected at all (in this case, landing at LSGS).

This happened for me with the Germany bush trip, and the Grand Alpine Challenge bush trip, but I suspect this issue is not tied to specific bush trips.

Hope this helps.



  • Finish first leg of any bush trip, around 90% of time it registers a successful first leg completed. Other times does not, bush trip over no POI’S no NAV but the course line remain in the vfr map.

*If first leg successful and I click continue, leg 2 starts loaded up the NAV and POI’S for the leg.
From there onwards, random whether the next leg or the leg after tht completes successfully.

  • If exiting the bush trip at any point, either to the bush trips menu or the main menu = no progress seems to have been saved, has been - start on runway on leg one.
  • However (ironically), the very first trip I ended up in bushes but aircraft clearly hadn’t sustained enough damage to the end trip. But could not take off without it taking critical damage and ending the leg, and was unable to start the first leg from the runway, everytime I restarted in the bushes.

I am still unable to complete 1 full bush trip, and have reinstalled the world updates 3 x times over. Help us !!

1 Like

Same exact issues with mine… just as described

Hi Jayne,
Thank you for your support with fixing bush trips. This seems to be our best chance of getting them working again as they were before SU5. As things stand now the only way to complete a bush trip is to complete each leg in succession without ever quitting back to the menus. My list of problems after SU5 is contained in ticket #131040 and since SU6 things have become worse with (for example) end of leg not triggering and games not saving at all making the ‘work rounds’ I have posted in the past no longer useful.
To answer your questions:

  1. Start a bush trip and finish the leg. If you return to any menu, the next leg no longer starts properly.
  2. This happens on all Asobo and third party trips I have tried. I publish bush trips and those which worked perfectly pre-SU5 no longer do.
  3. As you can no longer properly get past the first leg I can’t say. It makes testing new bush trips impossible so I have stopped making them for now until things get fixed.
  4. PC

I have completed all Asobo bush trips in the past and published more than a dozen this year free for the community. I look forward to everything being solved so I can get back to creating new trips.

  1. For me, it’s:
    a)Complete leg 1 of any bush trip I havent flown before
    b)Back out to the main menu and exit the game
    c) launch the game again and select the bush trip to continue, and load up the next leg (eg leg 2)
    d) once loaded in on the runway, there is no longer any flight path or POI markers displayed on the VFR map

  2. It has definitely happened on Discover Iceland, France (Bordeaux to Mont Blanc), and Balkans (Rijeka to Santorini), however these are the only bush trips I have flown so as far as I’m aware it’s any bush trip

  3. It does not usually happen to me until I leave the bush trip and reload it - so if I am continuing to subsequent legs without returning to the main menu I have gotten as far as leg 2 or 3 without it breaking but as soon as I leave the game it breaks and I can’t get the flight path or POI to return

  4. On PC

1 Like

OK I have been running Bush Trips from PERFECT FLIGHT(payware). And when I run any one of them…ALPS, Coast to Coast, Caribbean, etc. I can only complete Leg One. Going into the Missions\Activities folder for each one , I see 2 saved files for each one. …fs-act.save and …fs-act.save.001. I can open them with notepad and look at each one. The .001 file has the (GPS Engine) location saved but the first file is missing this section. I can then copy this over to the missing file and then run the Bush Trip sucessfully with the POI s in there. But I still cannnot get a completion when I land successfully at the destination airport. This then does not allow me to go on to the next leg #3. I get a washed out continue button. And this ocurrs on all my Bush Trips. I noticed that this never happened before SU5 came out. This is on my Windows 10 PC. I am using the Premium Steam Version of MSFS 2020

I got the same problem of saving my progression in bush trip !

1 Like

Even when I understand that it’s a kind of annoying, but does anyone remember the type of plane we have to fly with the Nevada bush trip!?

Therein you really really can only rely on the info given because the plane has nothing of a G1000 or whatever device!!!

Of course it would be nice to have at least the white line and the POI in the VFR map to keep showing.

But is it really needed within a plane!?

Maybe that’s the reason why you don’t have a flight plan anymore directly installed within the G1000 for instance with every trip so that we learn to fly VFR as how it originally in the old days was, even for passengers planes for that matter like those good old DC 3’s or even the old Boeings for that matter and you had to plan everything in advance.

Who knows that this was Asobo’s intention, for otherwise the info that comes along with every trip becomes completely obsolete, as you just can fly every trip by just keep following the CDI dial within the G1000, which I must admit gives you way less of the adventurous spirit in learning to find your way or way back, and thus with the Direct to option as the very last alternative for when you really got lost, or using it as a reference point put into the G1000 already at the departure airport for when you have visited the very last POI before having to fly to the destination airport.