Bush trips broken now?

So, I’ve been working my way through the Bush trips, enjoying trying out different planes, seeing different areas and trying to complete each leg using mostly visual markers (follow that road, go between that valley, landing strip is just the other side of that lake etc etc).

Im about a third of the way through them, but now im having major issues, in that it’s not saving my progress correctly.

The previous trip, Appalachians, i had to manually delete the save folder and start again, as for some reason, one of the legs half way through, it was starting me in the middle of the ocean and then into a black hole…
Deleting the folder worked, but upon completing the whole trip, it still says I’ve only done 66% of it, and the last 3 or 4 sections are greyed out.

Moving onto the next trip in Austria, i completed the first leg, but it says 0% completed and the first leg is greyed out, so i can’t restart from that leg to have it marked as complete and continue with the rest of the trip.

I haven’t changed anything in the sim, there’s been no update, community folder is empty apart from something for airmanager.

Not sure what to do, as deleting the save folder will mean starting the trips again and they still might not save? And i don’t know WHY it’s started doing this?

1 Like

ive been ‘trying’ to save bush trips since the beginning, ive still not managed to catch up because the trips break regularly.

im currently in the Beta so i can only confirm they dont work with my old saves here
this being the second time my old saves became obsolete - i didnt bother to save them after the first time, hopefully they will work again if they get it fixed

you ‘may’ be able to delete those last few legs only rather than delete the entire save folder?
more likely you will have to wait for them to fix it on their end
like i said this isnt the first time they broke them in this manner, i would bet if you look the legs that work have an extra file that the others dont have, im unclear if its because they all of a sudden required the file or didnt but …
inside each save folder you find each ‘leg save’ in separate folders, just delete the last 3 (or better save out to another location) and see if that allows you to fly the last couple missions - if the game is still broken i suspect it will ‘allow’ you to fly them but still not give credit so prob wont help but will get you to a usable point if/when they ever get it working again

Ah, didn’t realise i could delete individual legs, I’ll definitely look into that. I guess glad to know it’s not just me.

The annoying thing is that even though it’s clearly not saving things correctly, the game still gives an annoying stutter exactly every 60 seconds… because of the auto save lol!

I’m working on the Nevada trip. I’ve found that pressing ESC and exiting the game is the kiss of death. Try to start the next time and it’s totally unpredictable. To exit a leg go to the main menu, restart the leg, and then exit the sim. Like you, I had to delete a bunch of legs, drop back, not quite to the beginning, and start from a stable point in the journey.

I’d wait till after SUX later this month, as progress will be reset on Bush Trips anyway

Bush trips will work well if you follow this procedure at the end of each leg. When you have completed a leg and seen the ‘end of leg’ screen, continue straight on to the next leg. It will place you on the runway ready to start. Stay still until the white route line appears on the VFR map before quitting back to the MAIN menu. At present this will allow you to continue from where you left off later and will ensure you log the hours of your flight. In this way I have 100% on all Asobo bush trips that have been published to date. As you say SU10 is set to change aspects of bush trips and they will now be saved to the cloud so this advice may have a limited lifespan!

That’s brilliant. Thanks for the info. I’ll definitely try that next time. I’ve just deleted both trips i was having issues with. Unfortunately, deleting only the most recent file made it worse, showed no legs complete, but still 69% somehow… so i deleted the whole folder and will try exiting each leg as suggested going forward.

As su10 is not far away now, i might just take a break from Bush trips until it drops then.

Thanks again everyone… like i said, at least i know it’s not just me… the save system it’s obviously very picky and a bit bugged sometimes?

Tangentially related question: Is Bush Trip progress now being saved to the cloud on Xbox?

For example, I completed the three achievement-related bush trips and completed all landing challenges but didn’t get the “Completionist” achievement. Someone recommended uninstalling and reinstalling to get the achievement to trigger. When I did that, my Bush Trip progress was erased but my landing challenges were intact.

Still no Achievement so I’m re-flying the 3 core bush trips again in the beta to see if it will work this time.

TLDR: It would be nice if Bush Trip progress were saved in the cloud as opposed to being saved locally. Maybe I dreamed it but I thought I read in a recent update that the save location was updated but I can’t find it.

I think it’s only in su10 that saves them to the cloud, which is in beta on pc but due later this month on pc? Not sure about xbox.

Thanks again for the reply. Unfortunately, it still didn’t work correctly for me.

Well, half.

It does let me continue on the 2nd leg, or wherever i left off… but it still doesn’t mark the first, or previous, leg as completed… so it still shows 0% complete.

Anyone have any other clue why it would do this, or has noticed the same thing happen in their sim?

Not the end of the world, as things are changing soon… but just hoping i could resolve this first in case there’s some deeper issue with my sim?

Did you delete your previous saved game folder before restarting at leg one of the flight with the new technique?
Even if I was intending to fly the first two legs of a new trip, I would quit back to main menu from the start of leg 2 to ensure the save is correct before loading up the trip again back at leg 2.

Yup, this is after deleting the data and even on new trips that I’ve never done before.

Just tried again. This time, after completing a leg, and continuing to the next, I left the plane idling on the runway for just over a minute until the auto save stutter kicked in. It has now marked that leg as complete and can continue from the next. Still not sure if it’s the leaving it for 60 seconds that fixed it, or of its just random. Also not sure how it’ll work when i finish the final leg?

I usually wait for the white guide route to appear on the VFR map before quitting, if waiting for the auto save works for you, stay with it. It will only take a minute at worst.
After the final leg click ‘Continue’ on the leg/trip completed screen then go back to the MAIN menu. I have not had a problem with the final leg triggering in recent times by doing this and I have all Asobo trips at 100% as well as many third party ones.
Good luck!

1 Like

Nope. Must just be random.

4 legs through the appalachians trip and it’s now not marked my previous leg as complete again.

Done with trips for now i guess.

When su10 comes I’ll do a total fresh install of the sim and hope for the best

Omgosh, i might be a total idiot!

Does turning dev mode on/off affect Bush trips?

I think i might have had it on for part of the trips as i was also checking fps with different settings… (which, on my system, turns out, with default ultra settings, i get around 30 to 37 fps while my 2 Garmin displays are popped out, vs around 29 to 32 with every setting maxed out).

I’ve just completed another couple of legs (using the sit on runway for 60 seconds then exit method) and all marked as complete… no dev mode this time?

Could it be this?