Bush Trips broken?

I had the same happen during the Denmark run- ended up having to “drive” my aircraft from the janky starting point (dense forest floor) all the way to the destination AP to complete the journey of that particular leg. I hope this gets re-worked or a way to wipe errors.

For what it’s worth: the bug I files is “solved”.
Bush Trip sequences not working properly – Microsoft Flight Simulator Support (zendesk.com)
:stuck_out_tongue:

1 Like

Spot on. I just had this same problem and tried your method. Worked and saved me tearing my hair out and booting my Xbox around the garden in frustration. Thanks for that.

2 Likes

I have a workaround to the issue of the incomplete leg. I just experienced this at the Finland trip going from EFLL to EFRV. It did not register a completed leg when I landed in EFRV. Here’s what worked finally:

Exit to main menu. Back to Bush trip select last completed leg with a check mark. Choose “Restart From” button. Complete the leg (I use the Teleport Window in Dev Mode.) Then immediately Continue to the next leg. Don’t go to main menu or bush trip menu. Just choose Continue. Then complete the next leg (again, I used Teleport Window as I already successfully flew it.) This time the leg completes successfully.

Does’n work for me. Landed at EFKU and… nothing! No check. No navlog.
Don’t understand. Had a perfect flight.
Frustrating those not-working bush trips.

3 Likes

Please pop over here and add your vote if you have not already done so. The more votes, thegreater chance things might get fixed. SU5/SU6 and Bush Trips

2 Likes

Just be careful as Dev mode doesn’t log hours (so that might create some other logbook issues).

This worked for me. And also pretty easy. Thanks.

1 Like

Submitted a bug report today. Same as above, I love bush trips and they form the core of this sim, but they are fundamentally broken and it causes immense frustration.

  • Frequent faulires to register leg complete after sucessful landing at a destination airport.

  • Frequent failures to display VFR line or Nav notes on loading into a leg.

  • Information on Gamrin displays frequently wrong (or the nav system stops working but I guess tha’ts not Bush trip specific).

To date I’ve managed to complete 2 full bush trips, but am now stuck on legs 3-8 of 4 others and simply cannot bear to re-fly, load in, load out, re-land, edit files, delete, restart, quite to main ANY MORE.

I just wanna fly my plane over pretty scenery man.

Sorry, had to rant, but if this isn’t fixed I’m cancelling my gamepass as this is all I play for the moeny, and I can’t play it without immense frustration right now.

6 Likes

They’re so broken. If Asobo did even the slightest bit of testing it would be readily apparent.

The most die hard summers are treated as unpaid, ignored beta-testers. This has to change. Asobo taken notice.

1 Like

There may be some hope as the “Known Issues” blog was updated with this:

ACTIVITIES

Bushtrip progression is not saved when completing a bushtrip leg
    We are aware of this issue and the team is currently investigating

Fingers crossed!

3 Likes

What is the difference between the “known issues” page and “(Month) Feedback Snapshot.”

???

Are they not both tracking technical issues? It makes no sense why there are two lists. Who updates them? On what basis? How often are they updated?

Who is in charge of bug triage. I’d love to know how they have a job.

1 Like

I guess hope is all we got. I loved bushtrips during launch on gamepass and the saving worked back then. After many months I finally came back (bought the game) and I was also happy to see that there are so much more bushtrips and my excitement was high but it went down fast when I saw they are all broken :cry: The whole mode is 100% useless to me until it’s fixed.

5 Likes

The same for me - 2nd leg Denmark - after landing - nothing completed - reentering the leg - at the same airport without any guidence in the logbook… Managed to reflight it with renaming save - the same. I don’t want to pay addtional time for it:-(

2 Likes

Same here. Bush trips do not complete.

4 Likes

Still broken as of today…

2 Likes

Likely not going to get a fix until the next release at the earliest. If you haven’t yet, also give feedback to this post if your POIs were also disappearing:
Bush Trip POIs disappeared after first leg - Bugs & Issues / Miscellaneous - Microsoft Flight Simulator Forums

2 Likes

For me bushtrips are also broken (XsX). No Chance to complete the mont Blanc Bushtrip because the Andorra leg refuses to save my successfull landing…

2 Likes

C’mon let’s get the release out soon. This has been broken for so long. Tried every option but I’m not doing any more bush trip as I can’t move on from the last registered leg. Such a shame.

1 Like

Several fixes regarding bushtrips are coming with the next update!!

1 Like