C152 Aerobat Livery missing/broken on Xbox Series X

Please tag your post with #pc and/or #xbox.

Are you on Steam or Microsoft Store version?

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
No such thing on Xbox

Are you using Developer Mode or made changes in it?
No such thing on Xbox

Brief description of the issue:
The C152 Aerobat livery is missing a thumbnail picture in the menus, the airplane itself is missing both outside and inside livery/graphics in the hanger and in-game and cannot be used. All instruments have no graphics.

Provide Screenshot(s)/video(s) of the issue encountered:
Image Attached to support ticket 126185
Image uploaded to imgur

Detail steps to reproduce the issue encountered:
Started in world update 6 from what I can tell and remember.

PC specs for those who want to assist (if not entered in your profile)
Xbox Series X

Build Version # when you first started experiencing this issue:

Are you on the Steam or Microsoft Store version?
Microsoft Store on Xbox

Did you submit this to Zendesk? If so, what is your ticket #?
Yes, 126185

Remove and reinstall via Content Manager?

I’ll have to dig in and see which pack I need to remove. Not sure which one at the moment. I’m just on Xbox and have all the updates along with premium.

You should be able to use the search function and find the Aerobat as a stand-alone package. In fact, I’d try using aerobat as the keyword.

So I guess we can mark this as solved. I ended up trying to just delete the aerobat file but on Xbox it wouldn’t let me. So I deleted the deluxe package and reinstalled. I haven’t flown it yet but it did fix the thumbnail and in the hanger.

1 Like

You don’t need to delete the full deluxe package,but only the C152 Aerobat aircraft from the content manager.

But may be, this issue could have another reason.
Sometimes, after long flights or after achieving some bush trips, there is memory leaks causing textures to not being loaded (specially visible on airports, with lights/batiments displayed in pink).

After a memory leak, I had a similar problem; some aircrafts had transparent parts, and more fun, totally invisible in the hangar.
The solution was a full restart of MSFS (not a quick resume, as this mode keep the memory unchanged). After a restart, I got again the aircrafts well displayed in the hangar.

But there is others bugs with the C152 Aerobat… I recently discover that the CTRL + F10 cause a systematic CTD with this aircraft (and works fine with the classic 152).

When I did a search for the Aerobat in the content manager I saw both the deluxe package itself and the plane file itself but for some reason it wouldn’t give me a delete option when I tried to remove just the plane file.

The only other thing I could do was delete the whole package and reinstall. Luckily it was only 1.4GB.

As for the force quit, I had tried that as well and it was a no go. Fortunately the reinstall of the deluxe package fixed the issue. Appreciate the reply.