Call sign issues

This is a bit of a strange one, not long after getting the sim I set up my call sign as “Spook 2608” I forget exactly how I did it but it has worked perfectly on all planes with changing, atc always announced it and the nameplate in the various cockpits showed “Spk2608”

However, after the update the nameplate remains and says the same thing bit atc just announce “2608” if I turn on the subtitles they show “***** 2608”

The only place I can find to change this is in in the livery section of the plane before flight, but all boxes are blank, if I add “Spook 2608” either nothing happens (ie it stays the same) or it starts being announced and displayed in the subtitles as “Spook 2608 2608” as part of the old setting has remained.

Of course an few flight and it has gone back to the **** 2608

Any idea How I can fix this please ?

Many thanks all

Closed as a duplicate of:

Hi @SnideSpook ,

Before creating new topics in this category, please use the search function to look for existing topics. Duplicate topics can negatively impact the community by splitting the conversation, reducing the number of votes an idea receives and making it hard for users to find useful information.

You can use the search system by clicking on the magnifying glass on the top navbar. You can make use of the advanced search system by clicking the options link in the search box.

If you find an existing topic you can open that topic to leave feedback, or vote for the topic. If you can’t find one then you can create a topic - don’t forget to discuss the what, why and how.

If you want general advice on certain aspects, other categories may be more appropriate.