Can do ONE flight then either stuck on return to main screen or stuck on loading new flight

I have this in regular and save mode:
I can set up do exactly ONE flight with the world map and fly around with no problems.

Then:

  • It either stuck when I press back to the Main Menu (progress bar increases to “complete” very slowly ,that takes minutes) and then nothing happen. I have to kill FS in task manager and sometimes I have to reinstall the entire FlighSim because it wont start anymore at all.
  • Or if I make it to the main menu and try to load a new flight with the world map the flight will load up to around 70% (regarding the progress bar) and then increase very slowly to 100% without anything to happen.

It worked well till updated 9 came out. Hoped it was fixed by updated 10 but still the same issue.

Has anyone seen this happen, as well? Is there a work around? I’m desperate, don’t know what to do anymore and out of ideas how to fix this. I’m soooo tired of this. LOL

Topic moved into Community Support.

The Bug Reporting category is for confirmed bugs using the provided template.

ok, I think I figured it out.
When I reinstalled the flightsim I usually restored the flightsim data (~100GB) from a backup after installing the flightsim engine. it would just take too long to download the data over and over form the internet and I did a lot of new-installation. When I run the flight sim it would just download the missing data from the server after flightsim was upgraded as it would do, if you just update your flight sim to the latest version.

Well I think that this backup data over time was not clean anymore. There night be have been something inside to caused trouble.

So I decided to reinstall the flight sim from scratch including downloading the FlightSim ~100GB from the server and not it seems like I can load flights without problems. The only issue I had was the NEO (Leap) plane that seemed not to load and cause a stall when loading a flight. So I deleted that plane.

I have not tested yet on my oculus glasses but I cross my fingers.

I hope that is helpful to others if you have a similar issue.

Hendrik