Can someone ident this error?

I am trying to create a new airport where one exists in reality but doesn’t on MSFS. Bathurst NB Canada. CZBF just an empty field on the program… I have downloaded the latest SDK on C drive…and follow the pop up menus to create a new airport, not update and existing one on MSFS…
There doesn’t seem to be any updated videos that follow this new updated SDK>>

I keep getting this error

error… failed to copy file from.‘vfs://fs.devmode/edition/templates/assetgroups/bgls/airport-empty/ASSETNAME.XM’ to \C:airport test/Bathurst Airport/Packabesources\airport.--\sceneries\CZBF.xml

thanks

1 Like

Hi I have the same issue!

Same here :confused:

Well, now I am here with you three for the same reason. This must be a new issue. Has everyone just started recently with the SDK? I downloaded it for the first time to give it a spin. I tried to create an airport. This must have been before I noticed it had an update. So I updated the SDK and tried to remake the same airport. When it failed at this step I also tried to delete the original airport directory it had created then tried again with and without an overwriting of the directory.

Has anyone figured this out???

I have this issue as well. I have made a few airports prior to this with no issues. my favorite airport has gotton corrupted so i am trying to recreate it but cannot with this error.

Did you figure this out?

Yes… I have found the reason… The new version of SDK has some differences from early videos.

So for this instance… you must follow exactly

airportname

when you fill it in all small case… and no spaces even in the name the software will fill in the -

so it must look like example CYXX, Dish Island Airport will look like airport-cyxx-dishisland

The in the next line when it comes to naming it… you can use caps Dish Island Airport CYXX for example

Also if you are doing any custom scenery… I spend days trying to figure out why my textures weren’t showing… so if you want to put a model of a big house then when exporting from Blender using the blender 2msfs tool and following the videos you should use “texture” not “Textures” or “Texture”

at least that is my experience .

It should look something like

PackageSources
(airport name - generated by sdk)
ModelLib
Big_House (you create and then select in Blender export)
Big_House.bin
Big_House.Gltf
Big_House.xml
texture

              Sceneries

cheers

Sorry they didn’t ident the files above… anyway ModelLib and Sceneries are on same file level

ModelLib

texture(you enter this in before exporting)
Big_House (you enter this in)

Big_House.cin
Big_House.Gltf
Big_House.xml

Sceneries