Cannot access Reno Air Races after SU10


I have installed SU10 on my MSFS (Steam version) and I can no longer access Reno Air Races (base pack) that I recently purchased during last sale

When I go into Activities, the Reno Air Races picture shows “update available” at its top, when I click on the picture I am sent to Content Manager page that shows Reno Air Races installed (3,68GIB) and up to date

I have tried by removing and reinstalling the package but without success, the situation remained the same

Appreciate hearing your suggestions of how to solve this weird issue before issuing a ticket to support

Thanks in advance

1 Like

I am having the same issue here and have not yet found a solution.

1 Like


I opened a ticket to MSFS support and got quick answer with the solution: check individually all Reno aircraft looking for these still pending an update after SU10 installation.

In addition to Reno Air Races base pack, I had purchased one more Reno aircraft, P-51A Mrs Virginia, looking at it into Content Manager noted that it indeed had an update available!

I installed the update and, lol and behold! I was immediately able to enter Reno activities again!

Hope this solution will work with you as well

Happy flying contests!

1 Like

Thanks, FivePeach. That just worked for me as well.

1 Like

Awesome! I am glad being able to help!

Happy flying races!!!