Cannot activate approach mode in Working Title CJ4

This happens in both v.10.2 and v.10.3. It happens whether I use a full IFR flight plan or just tune the appropriate ILS frequency with no flight plan. I know the ILS frequencies are correct. I hit the approach button and I see it move, but none of the AP info on the PFD changes to reflect approa

Do you mean you see the approach button move?
Do the ILS indications show up on the PFD?
I take it you have checked (since you said the frequencies were correct) to see that the frequencies were actually there. That is a known bug. Often times they don’t auto -populate.

If you have done all that, try removing any other content from your Community folder and see if the issue is still there.

That’s not precisely correct. The ILS frequencies DO normally auto populate. However there is a bug with the latest release of the Sim which is preventing ILS frequencies from auto populating on ALL planes. Once that bug is fixed then the CJ4 will work as normal.

Thanks for the input!

I don’t think I said they don’t normally.
I said they often don’t populate automatically.
In other words: Frequently, you may need to populate the nav radio ILS frequency manually, as it may no do it by itself!

It isn’t aicraft specific.
The bug is an interaction fault between MSFS and (mostly addon) scenery.
Changes were made to MSFS in a file which is used to get acess to the runway navdata.
Third party scenery developers were made aware of the changes, but a lot sceneries still contain the old style file.
It was present for quite a while before the update, but became quite bad thereafter.
There are quite a few posts in here on that subject.
You can get the frequencies from the world map when you make your plan there, or freeware like Little Nav Map can be a big help.

I cannot get the approach mode to work in v.10.2 and 10.3 at all, even when I manually enter the ILS frequency.

I can confirm that ILS is working if you populate the frequency and if you use approach mode correctly.

Any problems I have ever had have been due to pilot error.

1 Like

Just completed an IFR/ILS flight on CJ410.2.

APPR worked just fine. Smooth landing.

The Scoreboard shows it active.

I created the flight in FS2020 as “new”.
And input the FP into the CJ4 FMS via “IDX”, etc…

MDAPOL. Please let me tell you how I input the ils and how I try to activate the approach. I have used both flight plans from the sim and putting in the ils freq. manually. Neither scenario results in the approach activating. In the case of manually inputting, I tune the ils with the keypad and then press the button to input it to the FMS. When I am ready to fly the approach, I push the button above the PFD and the ils frequency displays along with the alpha identifier for that approach. The CDI correctly shows my relationship to the localizer. The glideslope indicator correctly shows my position on the glideslope. Both these indicators change in the proper direction as I approach the runway, so I’m confident the approach ils freq. is correctly tuned. When I hit the Appr button, there is no change to the AP status indicators at the top of the PFD. “GS” never displays. The plane flies right through the localizer and will not follow the GS even if I hand-fly it on the localizer and then engage the AP. The same thing happens when I load the flight from MSFS. I follow all the steps set out by Working Title to do this, and the display shows that the flight plan is loading. I also call up the FP to ensure it loaded.
I never had this issue with v9.0 and earlier. If I am doing something incorrectly please tell me. Thank you for your help.

When you hit the APPR button, is the plane in NAV mode or HDG mode or ROLL mode?

Sounds like you are doing everything right. I believe others have mentioned there is a bug where you have to load the procedure from the FMS (DEP/ARR page) to enable Approach mode on the Autopilot / Flight Director.

Since 99% of the time this is how you would load the approach anyway, I don’t think many have come across the issue.

It is in HDG mode when I manually input the ils, because I just take off and fly a procedure turn with the AP on to intercept the localizer. It is in NAV mode when I load a complete IFR flight plan.

When you say, “load a complete IFR flight plan”, does this include loading the actual approach procedure from the DEP / ARR page of the FMS?

No. I load those from the MSFS flight planning page and then importing it. I’ll give it a shot loading from the FMS.

1 Like

What I’m asking is, right before you engage APPR mode, are you flying in HDG mode, NAV mode or ROLL mode?

How do you switch to APPR mode? Exactly? Tell me exactly what state the aircraft is in and exactly what buttons you push and when.

Actually, none of those should make a bit of difference. APPR mode should arm and capture regardless of what mode you are in prior to hitting APPR. (assuming the other parameters for capture are met)

JuiceBox: It finally worked when I input the flight plan manually into the FMS. Now I just have to get more proficient at doing that. Don’t know why it won’t work when downloading the MSFS flight plan into the FMS. Thank you for your help. Much appreciated.

Sure, glad you got it. I bet you will find you can get pretty quick at entering flight plans manually. I actually prefer entering it manually.

I’ve been able to get it to work when using the flight planner in MSFS as well.