Cannot download mandatory update

Rodger dodger. I just added a pic of the app I’m talking about to my previous post–the app is in MS Store.

In xBox, try going to My Collection (icon that looks like books in upper left. Then click on Manage Installs tab upper right. Good luck.

1 Like

So I kind of followed the advice above going to the MS Store and downloading the XBox Console. That didn’t help. So bottom line I clicked on my downloaded games, FS11 and it said it wasn’t starting properly and indicated to download the game again. I’m doing that now, all 131.96GBs. I’ll update you when I’m up and running in a day or so. But that seems to be my only option as there is NO update available in any of MS stores Xbox or otherwise.

Hi, guys. Here we are again suffering from the awful work by Microsoft and partners.

So, like everybody I couldn’t find the update to MSFS2020 in the Microsoft Store.

Following and advice found in the web, I uninstalled the game, and tried to install again, as it worked for some.

But now the install manager keeps coming back to the beginning when it reaches the end of download, on an eternal disgraceful loop.

If anyone can help, would really appreciate.

It’s so sad that such a great product is accompainned with such bad “infrastructure”. An udpate is supposed to be a very basic thing. And even that Microsoft can’t deliver.

In the meantime, I will be forced to go back to X-Plane until I’m able to reinstall this mess.

Thanks in advance,


I think the big issue was there are two Xbox apps in the Microsoft Store. One is the XBox Game Bar and the other is the Xbox app. It is the Xbox app that needs to be installed. I mistakenly installed the XBox Game Bar thinking that would work but of course it did not until I installed the Xbox app.

Thanks, man. Will try that. What a mess they have made.

Thank goodness for that sentence !
This showed the Fltsim Version I owned and clicking the icon to run and it at last downloaded the update
So 3 days of total frustration and it has now updated.
Why would a PC version buyer think you would need anything labelled X Box it is just not logical ?
I don’t know why they don’t put some effort into making this update process so much easier and automatic or at least some text telling you how to do it.

1 Like

Before seeing this post I uninstalled then reinstalled. This seems to have cured the problem for me. Yours is - no doubt - the quicker solution as I’m now waiting on 132GB download. At least I’m moving forward again.


Confirm. XBox App installed. Refreshed some minutes the store updates… there it is… what a mess. But worxx

I installed the Xbox app from the Microsoft store and then the update for MSFS2020 appeared in the store and I was able to install it. However the download of the update when launching MSFS2020 gets stuck after a couple MB out of about 3.29GB, [2/53]. Keeps looping with “decompressing…” (I can’t read the whole filename, it disappears too quickly). No idea why.

This update process is getting worse and worse, a proper launcher is sorely needed to manage installs and updates. Thank you Microsoft and Adobo for providing me with the very worst install and updates management of all the apps and games I have ever experienced.

wow, this answer unlock my MFS’s mandatory update stuck issue and let me back to fly. It really works.

This worked for me too. Its so crazy that we have to install a new software title (XBox) to update a game through the Microsoft store.

I’m glad that the XBox app fixed this issue for some of you. Didn’t for me, after spending hours with CTDs during WU6 update, I opted to uninstall and reinstall. Got 6.5 hours and 66GB in, and another CTD. Same issue as before. Run/CTD/won’t-run/repair/runs-again/mandatory-update/CTD.

Very frustrating!!!

thank you weaselport :+1:

Does anyone know why we have to have XBOX installed on the PC? I dont want XBOX - based on teh settings it looks like it’s going to interfere with my complex audio setup - i produce radio shows on this machine. And i resent being peddled games all the time - i dont want more games. I just have the one simulator and that’s all I want.


unfortunately installing new X Box app and all possible updates on the PC did not resolve it.
Still in the loop to look for the manadatory update in the MS store

The same problem for me: An update to 1.19.xx / world update is not possible! So far I have tried everything that has been written here, without success. I deleted the entire “Official” and “Community” folder and reinstalled MSFS from the X-Box app store. I deleted and reinstalled the X-Box app. But the old version 1.18.xx appeared again, without the possibility to load the latest world update on the marketplace (requires a new version). MSFS is not listed under Updates in the Windows Store.
I have activated a box version (Premium Deluxe Edition) from the Microsoft Store. I don’t know what else to do …?!? It just sucks!

Discussion why the X-box app may be required should rather be done here,
so that this topic can focus on troubleshooting.

It is completely absurd. I cannot play the title i bought and they didn´t fixed it yet! it is nuts.
And they want me to throw more money via marketplace? No way.