Cannot download mandatory update

The total was about 140 GB. I think speed will depend on your Internet connection. Mine is pretty quick so the download required about 90 minutes.

Tanx! I went through all the points again. Only after the last point did the MSFS appear in the updates after restarting the computer … Very strange. But thanks for the hints!

1 Like

Thanks for the help. I did resolve the issue and it was just that @ArizonaEagle235

1 Like

Installing the Xbox app worked. I had to open/close the Microsoft Store app a couple times but it finally recognized the need for the FS update.

I have a Premium Deluxe box version for #PC
Last time I updated a few days ago and all was OK, but now:
Game doesn’t start - I get: “Get mandatory update from Micrososft Store.”
In the Store I need a code which I don’t have!
And that’s it :frowning:

Download and install xbox app
https://www.xbox.com/en-US/apps/xbox-app-for-windows-10

Restart PC

Launch xbox app and sign in.

Recheck for updates in microsoft store app

2 Likes

Thank you - it worked! :slight_smile:

P.S. I amd surprised that Microsoft doesn’t think about instructing customers of such procedures when they publish updates. It’s not professional…

2 Likes

You’re welcome.
Mark as solution :slight_smile:

Also download updates from content manager and world update VI via marketplace.

Thanks of the heads up. I wil try to reinstall the gaming services.

At least for me, fiddling with gaming services (reset, repair, reinstall) seems to produce the ability to then install the update. Those options are found in Windows under 'uninstall" and then “more” . Interestingly, this update was the first instance in which MSFS 2020 loaded a prior version of the software (which seemed to work) rather than the current version. I also update Windows itself before fiddling with gaming services.
Next time they publish an update for MSFS 2020, I am going to fiddle with gaming services first.

The only way I could fix this problem was to re-install the sim. I tried all the other mentioned possible fixes, didn’t work. So re-install, that worked.

Searching I found this thread, But I have no luck with any of the above methods of mysteriously invoking the Store update to appear. I’m very tired of the BS, and repeated incompentencies of Asobo and or Microsoft for not providing in this year 2021 a seamless user experience, where is the accountability? Has anyone any further remedies?

1 Like

did mange to get it downloaded after trying several combinations of the above, don’t ask which ones.

It dosent help anyway, the server dwl atm with 0.01mbits only ;O(

This is truly the worst installation experience I’ve ever had. I bought this sim on steam, and for some god forsaken reason the speed was throttled to PEAKING at ~60mbit/s on a 300 mbs connection. Really have to wonder if they make it so slow so that you go past the 9 hour refund window on steam at this point. I’ve downloaded 100gig+ patches for other games without it taking 12 hours. Sorry to rant but this is infuriating. I restarted my computer/ the installer/ moved files/ done like half a dozen trouble shooting things i read online and managed to stagger my way through the install to the last 1 gig of the 127 gig mandatory content. I haven’t even been able to play the game yet and already logged 12 hours on steam… I’m now stuck on the last 1 gig and nothing is helping any more.

I think it has something to do with not using the default file path. I installed it on an m2 drive i have all my other steam games on which work excellently. I’m now trying to install the xbox app in a last ditch effort to get some value out of my wasted day and $60. Now the xbox app is stuck on “Making things awesome” with no % or any useful troubleshooting information. I’m dying to play this flight simulator but now i have concerns I may pass from old age before getting the game to start.

2 Likes

I have to agree with you. I installed this back at launch and the first install went fine, then a reinstall caused the download loop to start. Same issue this time. Decided to try the sim again after a year, and got game pass installed fine, played around for a week, tried to install liveries and got the file name too long error, so I reinstalled to a new directory and now I’m getting the download loop.

1 Like

Same here. This is the second time I have been locked out of MSFS. Mind you the first time I found that MSFS did not like Comodo Dragon. Uninstalled Comodo and all has been fine until this mandatory lockup. Sorry, I mean update.

1 Like

To download update you must update XBOX download first

I completely agree. I’ve never seen anything worse than this. Every update is a nightmare. I’m stuck on 512mb of update

Good luck! I got stuck on that one too today lol. Then i restarted the game and it said I needed to redownload 60gigs. so i restarted it again and it said I needed to redownload 10gigs… that got stuck on the last 2 gb but i just kept restarting the sim til it chunked through the last bit of the download. Never had issues with any other games like this.

1 Like