Cannot download mandatory update

You’re welcome.
Mark as solution :slight_smile:

Also download updates from content manager and world update VI via marketplace.

Thanks of the heads up. I wil try to reinstall the gaming services.

At least for me, fiddling with gaming services (reset, repair, reinstall) seems to produce the ability to then install the update. Those options are found in Windows under 'uninstall" and then “more” . Interestingly, this update was the first instance in which MSFS 2020 loaded a prior version of the software (which seemed to work) rather than the current version. I also update Windows itself before fiddling with gaming services.
Next time they publish an update for MSFS 2020, I am going to fiddle with gaming services first.

The only way I could fix this problem was to re-install the sim. I tried all the other mentioned possible fixes, didn’t work. So re-install, that worked.

Searching I found this thread, But I have no luck with any of the above methods of mysteriously invoking the Store update to appear. I’m very tired of the BS, and repeated incompentencies of Asobo and or Microsoft for not providing in this year 2021 a seamless user experience, where is the accountability? Has anyone any further remedies?

1 Like

did mange to get it downloaded after trying several combinations of the above, don’t ask which ones.

It dosent help anyway, the server dwl atm with 0.01mbits only ;O(

This is truly the worst installation experience I’ve ever had. I bought this sim on steam, and for some god forsaken reason the speed was throttled to PEAKING at ~60mbit/s on a 300 mbs connection. Really have to wonder if they make it so slow so that you go past the 9 hour refund window on steam at this point. I’ve downloaded 100gig+ patches for other games without it taking 12 hours. Sorry to rant but this is infuriating. I restarted my computer/ the installer/ moved files/ done like half a dozen trouble shooting things i read online and managed to stagger my way through the install to the last 1 gig of the 127 gig mandatory content. I haven’t even been able to play the game yet and already logged 12 hours on steam… I’m now stuck on the last 1 gig and nothing is helping any more.

I think it has something to do with not using the default file path. I installed it on an m2 drive i have all my other steam games on which work excellently. I’m now trying to install the xbox app in a last ditch effort to get some value out of my wasted day and $60. Now the xbox app is stuck on “Making things awesome” with no % or any useful troubleshooting information. I’m dying to play this flight simulator but now i have concerns I may pass from old age before getting the game to start.


I have to agree with you. I installed this back at launch and the first install went fine, then a reinstall caused the download loop to start. Same issue this time. Decided to try the sim again after a year, and got game pass installed fine, played around for a week, tried to install liveries and got the file name too long error, so I reinstalled to a new directory and now I’m getting the download loop.

1 Like

Same here. This is the second time I have been locked out of MSFS. Mind you the first time I found that MSFS did not like Comodo Dragon. Uninstalled Comodo and all has been fine until this mandatory lockup. Sorry, I mean update.

1 Like

To download update you must update XBOX download first

I completely agree. I’ve never seen anything worse than this. Every update is a nightmare. I’m stuck on 512mb of update

Good luck! I got stuck on that one too today lol. Then i restarted the game and it said I needed to redownload 60gigs. so i restarted it again and it said I needed to redownload 10gigs… that got stuck on the last 2 gb but i just kept restarting the sim til it chunked through the last bit of the download. Never had issues with any other games like this.

1 Like

My God, MS Store seems to be a disaster, if i was in your shoes I would uninstall the game and buy a new one from Steam, life is too short to have to deal with this mess.

This is ridiculous… why do I need the XBOX app to see the mandatory update? And why would microsoft not tell me that I needed it?

Known issue on the microsoft store that is affecting many games including msfs That why for now we need xbox app (in some cases)


1 Like

I tried all the fixes but none of them worked.
So I uninstalled MSFS and started from scratch with
To my horror when I first ran MSFS - the stage where afterwards I have to wait 36 hours during that long 128GB download - it again came up with the “… Mandatory Updatee …”. This was staggering since I had started with a fresh install.
I checked again , no updates were available.
Then the Update update appeared in the Store just after a restart. (It was issued the day before)
I installed that and now I am 16GB in to the 127GB download.

(This is around the sixth time, mostly in the last two months, when a complete uninstall and download is required for various reasons to get the program fixed and the second time trying to fix this issue; after the last reinstall MSFS was OK for about a week. )

I am not quite convinced that the various fixes, loading X Box App, restarts, uninstalling installing gaming services etc etc are actually fixes that deserve to be called a fix. They are more like the sort of fix for an unreliable car that won’t start where you kick it and bash it, try again and engine starts.

It may make the engine start but there is still a fundamental under lieing problem there that the Microsoft Software guys need to fix.

It should not ask to be updated when there is no update.

I even wonder if the problem is to do with local time differences.


Is it just a way of advertising Xbox? I wonder if XBox has a Windows11 App.

Discussion as to why the Xbox app may be required can better be done here:

IF they had TOLD US we needed the XBox App before WU6

Nope. Known issue on the microsoft store that is affecting many games including msfs. That why for now we need xbox app (in some cases)