Cannot download mandatory update

Yep me to had download issue
I downloaded Xbox app then closed it now mfs2020 update appeared :clap::+1:

Finally! A suggestion that actually worked! The web search for the app was key, still downloading so I have no idea if it actually worked yet, but at least I was able to get the update from the store

Issues is fixed… Once again update layers within layers… have never had the Xbox app loaded in the past, but now I have installed it launched MSFS from within the App, it reported a missing update again kicking me back to the Store. But make sure you restart after loading the Xbox app otherwise it wont pick it up properly.

Once restarted, it detects the Store update, then you can start MSFS and it pulls WU6 2.3Gb worth and then another ~5gb in the content manager.

I would think by now Asobo would have the update process sorted out, this “Sarah Lee” approach is frustrating.

Thanks everyone for your advice, and a Big shout out to AusFlightSimmer for his advice.

Here we go again with the screw ups … I’m having the same issue.

This Xbox app got it working for me too. Thanks, Proofy!

You download the Xbox App from the store, run the Xbox app, find FS2020 in there and click “Play”. This starts the sim which then shows “You need update blah blah” which opens the MS Store which FINALLY shows the update on the “Get Updates” page.

instead of downloading a APP I don’t use period they need to FIX this issue ASAPly… trying all these little workarounds is just BS…

1 Like

The update will not work for me.

I tried this

and this

I was only able to update the digital rights ownership app, but not the sim.

Sim only loaded once but was the old version, now U get the repeated update notice (when loading) with nothin on the store.

I am now stuck…unable to play.

Yes, Once I launched the Xbox App on my pc. Ran the game thru there, got the update message again. This time it appeared in the store.

What finally worked for me.

  1. Wsreset command in windows.
  2. sign out of x box app
  3. reboot
  4. sign into x box app
  5. run sim from x box app
  6. When kicked back to the store, goto to “download and updates” and then click “get updates”. MSFS one of three apps updated.

Note: For prior updates, the store would show an update install option in the “library” section. This no longer happens. I had to go to to the downloads and updates section and then select “get updates”

1 Like

Microsoft, you should be ashamed of yourselves. A simple update, you screwed up so badly, and yet you call yourselves a software company. For me, no update available, and I have to come here to read about the fixes to install a simple, straight forward update, none of which worked (one of the suggestions is to install X-Box version on my PC???) I classify your quality of work to be just above the cable companies. This just reinforces my justification in not wanting to buy your products. You won’t lose sleep over me now, but eventually, down the road, your company will lose out to your competitors. I plan on deleting MSFS 2020 and get a competitors product, and support them, hopefully to your detriment. Good luck in the future, you will need it.


When my download reaches %99 it resets back to %30. Re starts the FS base download again…What is going on?

I clicked uninstall game then went to install game and it updated and then when I went to launch game to install it then opened and game wasn’t uninstalled. Yep…

I have the same problem. I tried to do what you did; but the only Xbox app that was in the updates list was “Xbox Game Bar”. I downloaded it but FS2020 never showed up. Still need help because I can’t open FS2020.

Once mine did get passed all the XBox downloads and other prompts on the installation issues page the installation began. now a note. I relooked after the download and everything ‘owned’ and every passed earlier update needed to be ‘updated’ as well indicating a FULL update that’s rather intense.

I thought SU5 was disaster… :poop:

anyone having installation issues here you go
Microsoft Store - Download and Installation issues, Part II - Basic Troubleshooting – Microsoft Flight Simulator Support (

Ok, I got it to work. I had to download the Xbox Companion app from the Microsoft Store to get it recognize.

Now it say I need to download 15.1gb initial update was 2.2gb… This so ffffd

If you install the Xbox app from the Store and then Get Updates, the MSFS update will download.

Tried the simple “Xbox” app install, log in log out, no joy.

Went into the Microsoft Store settings via the Windows Settings (System → apps → Microsoft Store advanced options) and then “Terminate” followed by “Reset”.

Reopened Microsoft store and the update was available. Hope this works for some of you.

(Of note, I’ve tried real hard not to complain during this post about the fact that this pure beauty of a simulator is still plagued by weird bugs on every single update. I tried…)