Cannot download mandatory update

I tried all the regular tricks but gave up and reinstalled the program. It was about 4 hours from start to finish but that took care of things. :slight_smile:

I did a short (2D) VFR flight over the Ryukyu Islands (started from Naha and headed north) without any problems. I haven’t tried VR yet so we shall see. :slight_smile:

Edit:

I did an hour or so in VR (Quest 2’s) flying around Okinawa and I must say it was pretty decent. No crashes so far.

Hi all, I want to update the latest World update and I have gone to the Microsoft store and selected downloads and updates and it keeps telling me I’m good to go, it’s all updated. But is doesn’t download anything like it usually does. If I try to start the sim, it tells me to first install the new update and opens the microsoft store, but there is still no update available.

Am I wrong? The update is out for the whole World right, it is currently Wednesday 18 September 5pm in Auckland, I should see the the update right? I don’t have Xbox, so I don’t think I need the Xbox app

After learning that I need the XBOX app on my Win10 box, I downloaded it and then MSFS “said” it was updated to 1.19.8.0. But upon launching the app, its Installation Manager said I still needed a 43MB update. Once I clicked Update. the update box immediately disappeared (although it implied it had just started download 1/7), and the app required Repair in MS Store. So I repaired it, and was “good to go”. But, launching MSFS again told me I needed to update, and the cycle continues. I’ve been at it for hours.

I’ve restarted, repaired, logged out of and into both MS Store and the XBox app, and still cannot get past the Mandatory Update prompt. Can someone please help?

how did you uninstall ? Manually remove folders as well ? Or just from the MSFS-> uninstall ?
There are 5 stupid ways to uninstall none of which seems to work for me and i have no idea where they’ve hidden all the folders for me to manually remove.

I am in the exact same boat. I’ve uninstalled multiple times, removed xbox, signed in with diff ID but it keeps showing me this each time i start the game.


I doubt there is any official support since this is developed by multiple companies other than MSFT.
Earlier it shows 117GB but after uninstall and reinstall it is 132 GB and the best part is it is downloading at 2MBps which

All the Xbox app does for me when I click on play FS2020 is take to to the MS gaming services page on MS Store…I can’t even play at all or upgrade at all…

This just worked for me. I had to install the Xbox app. Checked for updates, nothing. But then went to the launch page of Microsoft Flight Simulator and then it started downloading the 509.8 MB update.

Looks like this is a result of MSFS2020 being tied into “Optimised for XBOX Series X|S” - only affecting PC users from the past year that don’t have the XBox app installed.

Left clicked on the windows icon in the lower left, then right clicked on “Microsoft Flight Simulator” and clicked on “uninstall.”

Once that was done I went to the MS Store and installed the program.

Why dont Asobo post installation instructions with the update? how do I know that Xbox app has to be installed first? Previous updates did work without it. I dont understand their logic whatsoever.

1 Like

This is worrysome I have a 150MB internet speed was 15 Mbits/s when I started but now is only at 0.76 Mbits/s that is worse then dial-up days.

Perhaps someone could help me. After being unable to update the way I have every other time: launching the sim, which prompts me to go to the Store, and I update, simple, so I read we now need the XBox App. Download it. Now whether or not I try to launch the sim from my desktop or the XBox App, it takes me to the Store and shows the XBox Game Bar app every time. From inside the Store, it shows no updates available. Its a vicious circle which is not getting me the update. Sim totally useless now. Re-boots after install of XBox App, before launching sim from desktop, before launching sim from XBox App. Have re-booted multiple times. Any help would be appreciated.

I had the same issue after trying all suggestions from ZenDesk still was a no go.

So uninstalled MSFS made sure all remnantes were deleted now I’m redownloading 131GiB’s at 6 GiB’s per hour that is going to take a long time.

MSFS needs a better way to do updates this is unreasonable.

any solutions for those of us on Steam and having the same problem?

Exactly what happened to me all afternoon yesterday. Guess I will give it another go this afternoon.

`installed the xbox app caused the patch 1.19.8.0 to appear as it should

Title says it all

Pc

And seriously i have other things to do than having to reinstall everything… please make a game (we get it it won’t ever be a simulator) that actually works

Agreed, I open the game it asks for a Microsoft Store update, then wont show any updates on Microsoft store! Such a uesless game with so many updates

3 Likes

Really, Microsoft, how to update if there is no update in microsoft store??? LOL
Clicking ‘Get updates’ → You’re good to go. All your trusted apps and games from Microsoft Store have the latest update. Where did you hide it. MSFT???

Good morning everyone… same problem for me too… open the game, indicates a mandatory update (I think precisely the 1.19.8.0 because at the moment I am stopped at 1.18.5.0 ) to download from the STORE … click OK… but on the STORE there is nothing … the problem is that it doesn’t even make you play without updating… to think that I just bought some new Thrustmaster hardware… I’ll put it in the cellar… sent a request to Microsoft… we’ll see… with the new updates we just are not there …

MOD EDIT (original text):
Buongiorno a tutti…stesso problema anche per me…aperto il gioco, ti indica un aggiornamento obbligatorio ( penso appunto il 1.19.8.0 perchè al momento sono fermo al 1.18.5.0 ) da scaricare dallo STORE…clicco OK…ma sullo STORE non c’è nulla…il problema è che non ti fa nemmeno giocare senza aggiornamento…pensare che ho appena comprato dell’hardware nuovo della Thrustmaster…lo metterò in cantina…inviata una richiesta a Microsoft…staremo a vedere…con i nuovi aggiornamenti proprio non ci siamo…

In fact, that’s right… all of Microsoft’s trusted apps and games are up to date… however… no, I’m very disappointed…

MOD EDIT (original text):
Infatti, proprio così…tutte le App e i giochi affidabili di Microsoft sono aggiornati…però…no, sono molto deluso…