Cannot get into VR after awhile. "The initialization og VR failed"

I emptied community folder and reinstalled WMR to no avail. I can switch to VR before flight and at the beginning of the flight, but after awhile, I cannot switch back into VR anymore, I get “The initialization of VR failed” message. This happened in the past, but I could get into VR if I just tried a couple of more times. But recently, it has stopped working all together, a few mins into the flight, if I am not in VR, or switch back to 2D, I cannot get back in anymore. I can use SteamVR to get back in, but this introduces a lot of stuttering, so it’s not an viable option.

This has just started happening to me as well with WMR via OpenXR. First flight is normal, but if I load up a new flight through the main menu, I get the VR has failed pop up window reminding me to have OpenXR installed to be able to use VR.

1 Like

I noticed OpenXR Developer Tools has been updated yesterday, and WMR itself was updated about a week ago, maybe that has something to do with this?

same issue here any ideas?

1 Like

If you put on the headset, are you still able to see the WMR home (Skyloft or whatever) or is the headset blank? What does the WMR screen on the desktop say?

I’ve had the error twice today. Don’t think I’ve seen it before. I updated OpenXR a few days ago & there was another update this morning.

The headset still worked when I got these errors… I could see the usual WMR cliff house… and I could even launch the OpenXR demo screen… only problem was when I tried switching MSFS into VR mode.
Only solution was to reboot the pc, which I did on both occasions.

Regards
Steve

I had this twice yesterday. Never happened before. Must be the OpenXR update that occured just a couple of days ago.

I ran into this over the weekend right after openxr update, happened 2 times in a row and required restarting the sim to resolve it, then it happened again.
I disabled the developer preview and it worked fine after that. I’ll wait till the next update to try the developer preview again but working fine now with the non preview version.

I agree. 18 August the OpenXR updated and I to no longer can enter VR after the first entry. I always dread mow as when entering VR on the first go I hope everything is working however I noticed that usually the mouse does not appear. I try everything to get it active to no avail. So you cannot do anything other than exit VR and try entering again. I then get the Initializing VR failed pop up window every time. The only way to get back in is usually exiting MSFS or sometimes restarting your computer. Time consuming and frustrating to say the least. I give up. Just another issue to deal with in this MSFS saga. It shouldn’t be this difficult. I think I’m dome. I might go and learn how to fly a real aeroplane. I’m most certain that I won’t have anywhere near as many dramas as this game gives us.

I get the same… Its an issue on ASOBO/MSFS side and have yet to be adressed (multiple trheads on this) but VR flyers is obviously not people MSFS want on their platform…

Biggest issue I get is that sometimes the mouse curser is not visible in VR. And after 8 months I have yet to figure out why… Now the only way to get it beck is to “reset” but going out and reentering VR which ofc brings with it a very high chance of the VR init failing and one having to reboot the whole sim… Man I cant wait for MSFS to get out of alpha testing :wink:

Try: ALT-TAB , cycle through the open apps back to the sim. IIRC, mouse cursor should reappear.

Tried that and a ton of other things, does not help, hope it stops mattering once we get vr controller support, but a real pain that costs me 30 mins to fix before everything is reset and back up and running for another run. (cant wait until Alpha testing is over :wink: )

VR crashing since Sunday evening! Hopefully whatever they are doing their end gets sorted. Perhaps it’s a result of testing new update or something along those lines :thinking::shushing_face:

Using live traffic / ai traffic? messing with settings etc?

I’m having the problem since update 6. "The initialization of VR failed. Please check that OpenXR is install. I’m using WMR with Reverb Headset. Works fine until I exist VR and reenter.

1 Like

I’m also having this problem since the latest world update. I never had it before.

Try disabling Preview Mode in OpenXr settings. It should work.

Thank you man, you saved me. I have already wasted a lot of time with this error, as you say, removing PREVIEW MODE in OpenXR panel, now works perfectly. Thank you.

1 Like