Cannot hear and see ATC instructions

Having this problem too.


I have the same on the flight I’m doing now. Can only see and hear my replies.
First time it happens to me.


Yesterday I could only hear and see my copilot’s replies, today I can only hear and see the tower ATC messages. I can’t hear my copilot’s voice and the text also doesn’t show up.
This is weird. ATC is unusable now. Pleople with this problem, please don’t forget to vote.


I have the exact same problem.
At the start of the flight I can both hear and read what ATC is saying. After some time during flight, I can only hear and read the reply of the copilot if that is switched on.


same here right now

Same here as well for the past few days.

Same issue here !!

The problem for me seems to be caused by the TBM Improvement mod. If I use it the ATC bugs out. Made 3 flights with it disabled and didn’t have the problem. Going to keep testing.

I too have the problem. It started about 1 hour into the flight. It has happened twice so far. I can see my co-pilots or mine, but cannot see or hear ATC. MS has to look into this, as I haven’t seen a solution here amongst the threads.

1 Like

Same issue for me, 3 days ago it was working fine even for 2h+ flights but since then I always lose ATC text and audio and only have my copilot text and answers.

@SnaggyTadpole48 , do you confirm that as of today you still have not encountered the issue anymore if you do the radio comms yourself?

Same issue here. Not all the time though, very random. ATC will be fine then just audibly stops. Your copilot can still be heard repeating the ATC so you have to go by their audio as to what to do rather than ATC audio. You can get text in the COM dialog back again by switching over to COM2 instead, but sadly no ATC audio, when it goes it goes on any given flight. It’s very random in nature though, some flights are fine from start to finish, others not.

Same problem here…although I could see and hear ATC reponses and instructions at the beginning of my cross-country flight but halfway through the flight I could not hear or see ATC instructions anymore. I could hear my AI copilot but not ATC.

1 Like

It’s happening on the Longitude also.


I find this strange as it has happened to me sometimes. The usual ATC voices are no longer heard, then it changes to different voices that are so different. My internet connection is pretty good, so I do wonder why sometimes these things happen.

That is probably just Azure servers being down. The voices are streamed I think, so if the streaming vioces drop then you get default ones. That isn’t the issue in this thread though, which is no ATC sound at all and no text ATC updates in window, just the copilot hearing the ATC and being able to read the co-pilots readbacks. It’s weird and random.

1 Like

Sorry it is a bit late but been having htis problem. I resolved it for me by tuning back on in Assistance Options/User Experience - Show message log in ATC Menu. Soon as the test was back so was the voice.
Hope this helps :slightly_smiling_face:


Thanks for this will give it a try next time it happens.

Same here, two days in a row. I can no longer see or hear the messages from the ATC, starting mid flight on the default 747 and on FBW 320.
I will keep testing and try this tip!

Edit: two hours flight with the B350 (without mod) without issue. Could it be an airliner problem?

I have the same issue as well. Tried all suggested fixes and nothing has worked.

1 Like

Happened to me tonight, but only after I activated “Flight Assistant/AI Radio Communications (ATC)”. While I was interacting manually with the ATC, I didn´t experienced any issue.
It would be nice Microsoft/Asobo paid attention to this.