Cannot Start/Update MSFS. Stuck on Gaming Services Screen

Anticipating the update today, I ran Windows Update, performed any updates from Microsoft Store. Earlier today, Gaming Services updated and then Windows Store updated itself. Now, whenever I try to start MSFS, I get taken to the Gaming Services page in Windows Store. The only problem is that there is no “install” button on the new store page.

I followed the steps in this article which I have done for previous updates, but it does not fix the problem. I still get taken to the Gaming Services page and cannot install from it.

Has anybody else run into this problem? Has anybody solved it?

Had the same issue today, out of the blue.
For me, this was the solution:
Try reinstalling the Gaming Services package on your Windows 10 device:

1. Right-click the Start button  in the lower-left corner of the main screen, and then select Windows PowerShell (Admin).
2. In the Administrator: Windows PowerShell screen, type the following command and press Enter:

3.Get-AppxPackage gamingservices -allusers | remove-appxpackage -allusers*