Can't access VR menu after update

Guys don’t forget that together with the toolbar after SU7 you can’t hide the virtual yoke anymore also atc is unusable anything that has to do with toolbar windows isn’t working

Thanks, BufordTX, it works! Good job.

Bill

1 Like

Also confirming that ctrl-0 seems to restore the mouse functionality in VR

Many thanks BufordTX !

Same, though I found that if I changed the keybinding for the VR menu it worked more often but still I often had to press it multiple times. Sometimes it would also cause the weather window to open but not the top menu.

Legend … Thanks

XBOX CONTROLLER WORKS WITH TOOLBAR

This is a ridicuolous bug, almost feels like Asobo are trolling us and did it for LOLS.

On the plus side, I have been able to use the toolbar and drag/resize maps in VR using an Xbox Controller.

It;s a bit clunky but at least I’m flying again.

You are awesome. Beer and brisket for you sir. Fixed the menu.

1 Like

I have also just noticed if I turn off my VR controller (G2) whilst in VR, the mouse and all functionality come back after the controller has powered off.

1 Like

Really? Please please tell me this is real. That would simply be amazing but I beg of you, tell me it’s not a wind up?

I have just tried this with Quest 2 and it made no difference. :weary:

Yep. Props to BufordTX! This is a great tempo fix until the devs can get the mouse / VR controls working correctly.

1 Like

No. . .this.

I’ll check a few more planes tomorrow, but so far works in the Porter and F-18.

1 Like

I have just tried the CTRL-0 workaround and it has indeed allowed all windows to be moved and interacted with (yay!) however, in this view, my assigned cockpit zoom button (right mouse button) became a spin the view around button and I could no longer zoom into cockpit (boo!)

How do I revert to the original view?

Go into the cockpit in VR and then push CTRL + 0 (zero). This worked for me. Shouldn’t be necessary but…Asobo

Same problem here. After nearly every update it feels as if I bought a bad early access game!

1 Like

The CTRL-0 workaround is a lifesaver for me in VR. I have assigned two joystick buttons (for me, hat-switch forward and hat-switch backward) to Instrument view 10 and reset cockpit view, respectively.

This allows me to switch to instrument view to open, position and interact with toolbar windows and then to switch back to cockpit view, to allow use of the, vital IMHO cockpit zoom function.

A bit of a nightmare TBH and during testing this, I somehow managed to make my ATC window so far away, I couldn’t read it LOL, but it only happened once and after dropping out of VR and back in, it was back to normal size.

1 Like

We should not be forced to use workarounds for a Bug that should not exist in the first place, yet again I’m amazed that such a major game breaking issue is allowed to be released with an update with no hint of a Hotfix or tiniest apology in the Known Issues notes.

It’s like getting your car back from a service but being total the steering wheel doesn’t work, sure you can start the engine, turn the radio on and even change gear but you’re pretty much stuck without the main control.

This needs rectifying and it needs rectifying immediately, this is not a good way to treat your customers.

6 Likes

ctrl-0 works so I am really happy with this temp. fix.

However, I noticed VR focus was no longer working (JustFlight PA28 III). Anyone else experiencing this?

Update: tried again. Before pressing ctrl-0 the VR focus (zoom) works fine, but after pressing it it no longer works. Also tested in default C172.

Having no zoom is still better than having no toolbar though.

You need to press CTRL-SPACE to reset cockpit view and regain cockpit zoom functionality…and then CTRL-0 again when you want to interact with toolbar windows. See my post above.

3 Likes

Thanks! Missed that one!

1 Like